SpywareBlaster 4.5 released!

Discussion in 'SpywareBlaster & Other Forum' started by javacool, Nov 28, 2011.

Thread Status:
Not open for further replies.
  1. javacool
    Offline

    javacool BrightFort Moderator

    SpywareBlaster 4.5 has been released!

    Prevent the installation of spyware, malware, and other potentially unwanted software!

    New in this version:
    -Added Pale Moon browser support.
    -Improved support for the latest versions of Mozilla Firefox.
    -Improved support for certain non-standard user account configurations.
    -Improved installer experience on Windows Vista/7.
    -Fixed rare updating issues.
    -Numerous other bug fixes, optimizations, and tweaks.

    Also, Flock browser support was removed in this release. The Flock browser is no longer actively maintained or supported by its makers.

    This 4.5 release provides enhanced protection, browser support, performance, and bug fixes.

    UPDATING OPTIONS IN SPYWAREBLASTER
    SpywareBlaster still offers the built-in Check for Updates feature. This feature is completely free and allows you to keep up-to-date by clicking on a button in the SpywareBlaster interface.

    SpywareBlaster also offers SpywareBlaster AutoUpdate - a sleek, automated, no-nonsense updating solution. Just set it up, and AutoUpdate will check at every system boot for the latest updates and enable the newest protection (other options are available).

    As much as we would like to provide auto-updating functionality for free, costs are simply too great to make it feasible. AutoUpdate functionality is available for a low fee, which helps to cover the bandwidth costs. The Check for Updates function remains completely free, as does SpywareBlaster. You only need to pay if you wish to have the extra convenience of AutoUpdate.

    SpywareBlaster is freeware.
    Download the latest version here:
    http://www.javacoolsoftware.com/spywareblaster.html

    System Requirements: Windows 98, ME, NT4, 2000, XP, Vista, 7. (32 and 64-bit)


    Enjoy! :D

    Best regards,

    -Javacool

    P.S. If you have any problems please don't hesitate to post.
  2. javacool
    Offline

    javacool BrightFort Moderator

    Requirements:

    Windows 98, ME, NT4, 2000, XP, Vista, 7. (32 and 64-bit)


    Provides Protection for the Following Browsers:
    • Internet Explorer
      and any browsers that use the Internet Explorer engine, including:
      • AOL web browser
      • Avant Browser
      • Slim Browser
      • Maxthon (formerly MyIE2)
      • and more
    • Mozilla Firefox
    • Netscape
    • Seamonkey
    • Pale Moon
    • K-Meleon

    Slim Operation:

    As always, SpywareBlaster doesn't use any services, drivers, or anything that constantly runs in the background, consuming your computer's memory and processing time. You just open SpywareBlaster, set your protection, and close it - you're protected.

    And it works great with other reputable security and privacy applications, including anti-virus, anti-trojan, and even other anti-spyware programs. There's no such thing as a 100% effective solution, and SpywareBlaster was designed from day one to be a compatible, effective part of any security setup you may want to configure.
  3. javacool
    Offline

    javacool BrightFort Moderator

    Upgrading Tips:

    To upgrade SpywareBlaster from a previous version you can either:
    (a) Download and install the new version of SpywareBlaster "over-the-top".
    (b) Uninstall the old version of SpywareBlaster first. Please see the detailed upgrade instructions here: http://www.javacoolsoftware.com/sbupdate.html

    Either method should work.
  4. m00nbl00d
    Offline

    m00nbl00d Registered Member

    Thanks for the update. :thumb: Damn... still no localization, though... :D Maybe the future reserves some unexpected feature to us all... :D
  5. hayc59
    Offline

    hayc59 Updates Team

    Thanks J..installed and posted ;)
  6. m00nbl00d
    Offline

    m00nbl00d Registered Member

  7. Joseph Collins
    Offline

    Joseph Collins Registered Member

    Well now isn't this funny? Today, I registered a new account on these forums (with some very speedy assistance from the forum maintainers at Wilders Security!) to report an issue with SpywareBlaster not recognizing profiles with relative paths in Firefox v8.0 (which seem to be absolutely mandatory in this version of the browser)... and just as I finally get ready to post my report, you guys release v4.5 of your awesome product and fix the problem straight away! How cool is that? And how funny, considering I just noticed this irregular behavior today. (I've been unprotected by this program in Firefox for how long?!)

    Keep up the good work on this thing, Javacool! I've been using it for the past couple years and plan to continue using it for as long as it's updated!
    Last edited: Nov 28, 2011
  8. siljaline
    Offline

    siljaline Registered Member

    Most excellent, javacool :thumb:

    I have elected an install over top since I have some hosts safe backups and a few other tweaks that would remain as-is with an install over top.

    Thanks for the great continued work !

    Blogged, Tweeted and posted to my Facebook community.
    Last edited: Nov 28, 2011
  9. Daveski17
    Offline

    Daveski17 Registered Member

    Yes, thanks for the upgrade Javacool. I installed 'over the top' & it seems fine. :thumb:
  10. FanJ
    Offline

    FanJ Updates Team

    Thank you very much JC :thumb: :D

    I did a clean install on XP-home SP3. Sofar all fine :)

    Thanks again for all your hard work ! :thumb:
  11. redwolfe_98
    Offline

    redwolfe_98 Registered Member

  12. Trooper
    Offline

    Trooper Registered Member

    What is your Twitter if you don't mind me asking?

    Thanks and Cheers!
  13. m00nbl00d
    Offline

    m00nbl00d Registered Member

    The download is done from here -http://www.javacoolsoftware.net/downloads/spywareblastersetup45.exe

    BitDefender blacklists it... o_O
  14. atomomega
    Online

    atomomega Registered Member

    How can I make sure K-Meleon is being protected? I don't see Mozilla Firefox being detected on SB's GUI, assuming it would match K-Meleon's rendering engine.
  15. niki
    Offline

    niki Registered Member

    Thank you so much for the update. I posted in Pale Moon browser forum to let them know that you support their browser. They're very pleased about it and so am I. :thumb:

    Prior to this update, Pale Moon info would be shown under Firefox in CCleaner.
  16. Eddie_NC
    Offline

    Eddie_NC Registered Member

    About your fix for the "rare" update problem ... this new version will not update for me. I've downloaded the installer twice and reinstalled it that many times ... of course rebooting each time. I don't want automatic updates. I do my updates manually. Since I have limited and intermittant access to the internet, I prefer not to have my programs trying to update automatically at bootup.

    I installed the new version with that option each time. The install went fine every time and everything seems to work as it should until I try to manually update the program. Then my laptop locks up and has to be forced to shut down in order to regain control. I've used the free version of SpywareBlaster for a long time and this is the first problem I've ever had with it.

    System is a Gateway Laptop with two gigs of Ram and 160 GB HD space running Windows Vista with SP1 and SP2. Vista is updated twice a week and is current. I'm also running ZoneAlarm and Spybot S&D concurrently with SB but as I said, I've not ever had a problem with my setup till now.

    Has anybody else had this problem?
  17. m00nbl00d
    Offline

    m00nbl00d Registered Member

    Could it be an issue between SpywareBlaster and Spybot's TeaTimer (if you got it enabled) or ZoneAlarm?

    I got relatives using SpywareBlaster and Spybot (without TeaTimer), and they don't have the issue you report. They don't use ZoneAlarm, though.

    Hopefully, someone else, probably Javacool Software staff, will be able to provide you with a better assistance than mine, but it could be worth trying and see if any of those other security applications are conflicting with SpywareBlaster.
  18. Page42
    Offline

    Page42 Registered Member

    I did clean installs on two XP, SP3 computers.
    Smooth as is always the case with Javacool's software. :thumb:
    I wanted the most current version for those rare times when I use IE8 instead of Chrome.
    Thank you for the dedication to this program, Javacool. :thumb:
Thread Status:
Not open for further replies.