Remote Desktop does not work with Automatic filtering Mode

Discussion in 'ESET Smart Security' started by johnye_pt, Mar 15, 2009.

Thread Status:
Not open for further replies.
  1. johnye_pt

    johnye_pt Registered Member

    Dec 29, 2008

    My home computer is setup with WOL (Wake On Lan) so i can turn it on whenever i need access to it from work or any other place.

    The problem is that i can't logon with Remote Desktop when Smart Security 3.0.684 is in "Automatic filtering Mode", only when it is in "Interactive Filtering Mode" or "Policy Based filtering Mode". I'm not using default port 3389.

    What i did so far:

    1. Uninstalled Smart Security, deleted any key or folder regarding ESET (including documents and settings\user\application data or local settings), and reinstalled with "Interactive Filtering mode";
    2. When in "Interactive Filtering Mode", i accepted incoming Remote Desktop connections from a local computer (LAN) and from my computer at work (Internet), 2 rules were created for svchost.exe;
    3. If i change it to "Automatic filtering Mode", i cannot start a Remote Desktop connection with or without a user already logged in (if that makes any difference);
    4. I tried manually creating the rule, still didn't work.

    Windows Firewall and ZoneAlarm never gave me this problem, but i'm also new to Smart Security so i might me missing something. Any help is welcome.
  2. Stem

    Stem Firewall Expert

    Oct 5, 2005

    Automatic filtering mode will act the same as the windows firewall with "Dont allow exceptions"

    For what you want, at step 3, select "Automatic mode with exceptions"

    - Stem
Thread Status:
Not open for further replies.