PE SocketSpy bug?

Discussion in 'Port Explorer' started by George S, Apr 15, 2003.

Thread Status:
Not open for further replies.
  1. George S

    George S Guest

    When I try to open Socket Spy is open into the task bar, but when I try to click it, it hangs and the SocektSpy gui never opens, so I can't view the packets. Any suggestions?
     
  2. Jooske

    Jooske Registered Member

    Joined:
    Feb 12, 2002
    Posts:
    9,713
    Location:
    Netherlands, EU near the sea
    This is new for me, which windows version were you running again?
     
  3. Jason_DiamondCS

    Jason_DiamondCS Former DCS Moderator

    Joined:
    Nov 11, 2002
    Posts:
    1,046
    Location:
    Perth, Western Australia
    I recently got an email about this from one other person who said he couldn't see the socket spy window sometimes. It seems there is something wrong with the window position getting saved ALL the time, but when I looked at the code I couldn't find a problem :( . Anyhow this is the fix.

    Load up regedit (click on the start button then click on RUN then type "regedit")
    Go to "HKEY_LOCAL_MACHINE\DIAMOND COMPUTER SYSTEMS\Port Explorer"

    In there you will find Port Explorer's settings, look for "SocketSpyWidth, SocketSpyHeight and SocketSpyTopLeft" . Just delete those 3 values and try loading Socket Spy see if that solves your problem. If it does there may be a bug in the window saving code that may need to be fixed.


    The person who emailed me had an incorrect SocketSpyTopLeft . If you wouldnt mind posting what VALUES you have in there before deleting them, it would be appreciated.

    Thanks George.

    -Jason-
     
  4. Jason_DiamondCS

    Jason_DiamondCS Former DCS Moderator

    Joined:
    Nov 11, 2002
    Posts:
    1,046
    Location:
    Perth, Western Australia
    I just found out why the Socket Spy window bug occurs. If you close down the socket spy window after you have minimized it, it saves the minimized POSITION to the registry which means next time it reads those registry settings the position is still "minimized" if you know what I mean. The current solution is to not close down Socket Spy window when its minimized. This will be fixed in the next version.
    -Jason-
     
  5. George S

    George S Guest

    Thanks, in case it will still help:

    SocketSpyHeight = 18c
    SocketSpyTopLeft = 7fff7fff
    SocketSpyWidth = a0

    And I deleted all 3.

    And the window it back! Thanks.
     
Thread Status:
Not open for further replies.