Paragon Go Virtual displays "No Windows OS"

Discussion in 'Other Paragon Disk Utilities' started by zmerch, Oct 28, 2010.

Thread Status:
Not open for further replies.
  1. zmerch
    Offline

    zmerch Registered Member

    I downloaded the latest version of Paragon Go Virtual as I'm trying to virtualize my Win7 32bit installation in hopes of using Linux at work. (I use a few applications that require Windows - they won't run in Wine)

    Downloaded and installed the product, start the product, and everything seems fine...

    I select P2V Copy, I select the entire disk & click Next, and Go Virtual scans the disk and errors with:

    "No Windows OS found. Please select at least one volume with installed OS."

    This is the boot drive, and it's booting into Win7. (More specifically, the ver command shows: Microsoft Windows [Version 6.1.7600] )

    Does Go Virtual have issues with making virtual disks from currently running physical disks? Do I need to boot from a different media (live CD, etc) first?

    I've tried Disk2VHD from sysinternals (which almost worked - VM bluescreened in normal mode, would boot into the repair utility but wouldn't repair), the tool from VMWare (VM just BSOD's) and now this tool, and I guess I'm just not feeling any love... ;)

    Machine is a Dell Latitude E6510, dual-core i5, 4G RAM, 250G HD (about 40G used), and has 4 partitions: the DellUtility partition, about 200Meg (9 used) which I think is nonbootable & FAT16, the RECOVERY (caps not for emphasis, they're the title of the partition, didn't mean to yell) partition which I think is also the bootable/active partition & is NTFS, 750Meg (200 used), the OS partition which shows up as C: - also NTFS, and one extended partition titled "Reader", it's D: and it's 2G FAT32 with only 4Meg used.

    I really didn't want to spend personal $$ on something I only will do once...

    If anyone needs more info, please feel free to ask!

    Thanks,
    Roger "Merch" Merchberger
  2. Mech_An
    Offline

    Mech_An Registered Member

    Roger,

    Please try the following:
    * find 'dcpromo.exe' in C:\Windows\System32\
    * temporary rename file
    * run P2V

    Does it work?
  3. zmerch
    Offline

    zmerch Registered Member

    Yes, that worked. I have now transferred my Win7 (in preparation for my "eeevil plan" of running Linux at work :) ) and thus far, this is the only free application that actually worked "right" - Win7 booted fully and is working; albeit it doesn't currently think it's genuine.[1]

    [1] I disabled all the network ports in Virtualbox, as I'm testing this clone on the system it's cloned from - if I put 2 machines named exactly the same on the network, I suspect it would confuse the domain controllers & whatnot immensely... so I need to run the Virtual Win7 outside of the real Win7 next, before I can go authenticate it.

    One small question (and it's so small that I probably shouldn't ask this... ;) ) but I checked the box in the utility to make a VirtualBox .vdi file, but it made a VMWare .vmdk file. (Come to think of it, it's called vdisk0.vmdk which I'd assume is a "default if you don't specify the filename" -- I originally specified Windows_7.vdi); is it supposed to do that?

    Again, VirtualBox had no problems opening this file & running Win7 so I'm happy as a clam. I have *no* problem converting it to a .vdi manually, so again - no worries there. If logs from the process would help you, I'd be happy to re-run the utility and save the logs for you, if the logs aren't cumulative.

    Again, thanks for the fast and accurate response, I'm a happy camper now.

    Thanks!
    Roger "Merch" Merchberger
  4. Mech_An
    Offline

    Mech_An Registered Member

    1. Windows is not genuine:
    http://kb.paragon-software.com/para...atId=2124&objId=6818&statId=1541983&foLang=en
    Windows 7
    http://technet.microsoft.com/en-us/library/ff793428.aspx
    [...] Periodically, Windows 7 and Windows Server 2008 R2 check the hardware configuration of the computer on which the operating system is installed. If the operating system detects that the hardware has changed substantially, reactivation is required.[...]

    2. *.vmdk instead of *.vdi and wrong VHD name:
    Could you please try to repeat p2v conversion and check if it works the same way?
  5. zmerch
    Offline

    zmerch Registered Member

    Yup, I've activated WinXP many times over the years; I had to phone the "computer lady" to get 7 activated again, but it's working fine now.

    Yes, I tried several different ways:

    I tried the following methods both logged into the domain with my personal ID on the domain (of which I'm an administrator) and as the local computer administrator outside the domain. However, I only tried to make Oracle Virtualbox virtual drives; I didn't try any other options (like MSVirtualPC).

    1) Went through the wizard choosing the defaults for everything; (and the directory it chose was c:/Users/zmerch/.VirtualBox/)
    2) Went through the wizard specifying the full directory to /Users/zmerch/.Virtualbox/HardDisks through the 'browse' button
    3) I noticed that during the first 2 instances that the 'browse' button uses slashes '/' instead of backslashes '\', I also tried manually typing c:\users\zmerch\.VirtualBox\HardDisks

    I chose slightly different filenames / machine names each time, every time out of the 6 it started building a vdisk0.vdmk file. It put it in the correct directory specified despite the slash/backslash issue (Maybe Win7 handles those better, I can't say for sure ;) ) but it never used my specified machine name or the .vdi extension.

    The other thing I cannot say is if the file format itself is correct for .vdi but just has the wrong filename extension, or if it really is a VMWare file - If there's an excerpt of the file that would help you, I'll be glad to make that available...

    { Sarcasm: However, as much as I really want to help out, I'm not uploading a 40G file... ;) }

    I now have access to linux tools & whatnot again, so I'm quite sure I could figure out how to grab the first/last 500K of a file (or whatever you might need) and put it in a publicly available space.

    Again, I just want to say "Thanks!" for a great tool and everything I need is working now, so this post isn't "OMG its broke!" it's "Need a hand? I'll bring the beer..." ;)

    Thanks a lot!
    Roger "Merch" Merchberger
Thread Status:
Not open for further replies.