Opera 12.14 strange google display

Discussion in 'other software & services' started by act8192, Mar 12, 2013.

Thread Status:
Not open for further replies.
  1. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,084
    Ever since version 12.14 of Opera, on few sites I get their menus displayed incorrectly.
    Google search page, for example, puts the words on the left, vertically into a narrow column, like this.
    GoogleDisplay.jpg
    The strange thing is that a button "Fit to Width" repairs the display, the usual google black bar with words gets filled.

    This makes no sense to me. Might there be a more relevant way than Fit to Width to get the display correctly right away?

    I'm on XP-SP3.
     
  2. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,084
    Bump :)
    I hate doing bump, but I believe there are Opera users here who might be seeing a similar silly looking display.
     
  3. Wild Hunter

    Wild Hunter Former Poster

    Joined:
    Oct 13, 2012
    Posts:
    1,375
  4. Mman79

    Mman79 Registered Member

    Joined:
    Sep 19, 2012
    Posts:
    2,016
    Location:
    North America
  5. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,084
    I finally figured it out.
    Google didn't like user agent. I had to change it to pretend it's Internet Explorer instead of the normal Opera I've been using for years.
    Google also used iframes, but that they will not get from me.
    I can't really read source, but a bunch of script statements are of the sort 'if it's Chrome - display...' otherwise display blank. At least that's what I think I see. But that doesn't really match the fact that Seamonky was ok. So I don't really know what's going on and it probably doesn't matter at this point.
     
Thread Status:
Not open for further replies.