OA Premium and SBIE on Win7 x64

Discussion in 'other firewalls' started by chris1341, Jan 18, 2012.

Thread Status:
Not open for further replies.
  1. chris1341
    Offline

    chris1341 Registered Member

    I've been running AppGaurd and SBIE lately on my machines with no real issues but getting a liitle bored as its too easy :D

    Decided to throw OA Premium back into the mix and remove AppGaurd and see how things go. Disappointingly I can't seem to get SBIE and OA to play well together at all. I know Emsisoft say the latest version solves compatibility issues but not for me.

    Effectively Iron (or any Chromium derivitive) won't work. All I see is the 'Aw snap' animation although it works fine sandboxed with OA disabled or with OA unsandboxed.

    Firefox takes nearly 30 seconds to start instead of 2. Again no issues when the apps run independantly.

    Office applications, including Outlook, start (very slowly) but throw a 'stopped working' message. Again fine under the control of a single application.

    The same whether the apps are set to 'run-safer' or not and Sandboxie 'experimental' on and off. OA template in SBIE is in use and all the apps in question are trusted by OA. The only way to resolve it is to exclude Sandboxie AND the sandboxed applications from OA protection. Seems ridiculous to exclude your main internet facing applications from your firewall though. OA logs say nothing and Sandboxie Resource Access Monitor seems to be normal.

    I can't find any recent (post the OA changes) reference but is this a known issue? Any other ways of resolving it?

    Thanks
  2. Brummelchen
    Offline

    Brummelchen Registered Member

    last first - OA as firewall and sandboxie work well together - but i didnt used "run safer" as sandboxie already has that feature. also restrictions with
    sandboxed programms and OA firewall - i had SB as excluded cause
    sandboxie can handle web access itself. on the other hand OA HIPS
    is usable beside sandboxie.

    OA premium only include Emsisoft AV as a seperate installation, still two products afaik.

    BTW should the emsisoft support not your first partner here?
    afraid i cant help further as long i dont use OA any longer, too much switches
    for less use here. and emsisoft av 6 slowed me extremly down.


    PS just read
    http://sandboxie.com/phpbb/viewtopic.php?t=12277
  3. chris1341
    Offline

    chris1341 Registered Member

    Thanks, yeah probably should have went to Emsisoft forum but I trust Wilders above all and I know the Emsi guys and some SBIE experts visit regularly.

    Anyway its not a run-safer issue as I don't use it for sandboxed apps. As you say SBIE is safe enough.

    Don't mind excluding SBIE. Good practice to exclude your other security products IMO. Its the fact I need to exclude the apps themselves as well that I don't like and think is not really how it should work.

    Cheers
  4. chris1341
    Offline

    chris1341 Registered Member

    Loaded a cleam image that has had neither app on it before - installed them again OA first then SBIE, then when that didn't work switched that to SBIE first then OA. No differences noted still unable to get them to work together.

    Patience is a virtue I've never posessed and if it wasn't for the fact I like the new files/registry rules in OA Premium I'd have given up by now.

    I'll ask at some point on the Emsisoft forum and if I get anything post back for anyone who may have a similar problem in the future.

    Meantime can someone confirm 'excluding' in OA excludes from both Firewall filtering and HIPS activities i.e. excluding my sandboxed internet facing apps in OA means internet traffic to/from them is unfilitered?

    Cheers
  5. justenough
    Offline

    justenough Registered Member

    I'm running 7 x64, OA Premium everything on, and Sandboxie Experimental. Haven't had any problems.
  6. chris1341
    Offline

    chris1341 Registered Member

    Thanks for letting me know. So many variables on systems there will likely be some other seemingly unconnected issue impacting for me or my SBIE restrictions, who knows. I've also had complete lock-ups using the VT up-loader and MPC-HC related to OA so.......

    I'll see if I get anything from the Emsisoft forum. If not give up. OA is good (I really like the file rules) but its not as if there are no alternatives.

    Cheers
  7. Function
    Offline

    Function Registered Member

    I use all 3.

    AppGuard
    Sandboxie
    Online Armor Preium

    I have been having issues with Chrome, its my secondary browser and using it inside the sandbox all I get it is the "aww snap" image as well. Nothing seems to work inside a sandbox, outside however works fine. It runs fast both in and out of a sandbox. As I don't care for chrome at the moment I just installed it. I have no clue how to fix this one.


    Firefox works well for me both inside and outside the sandbox. I did disable the Sofware Compatibility for Online armor and everything seems to run well. Banking mode kills all websites but my bank so I assume that Online armor is still working inside of the sandbox even without the compatibility turned off. It still takes ages to load within a sandbox but once it loads everything is fast.


    I don't use outlook but I do use Thunderbird and it runs in its own Sandbox. I have had 0 problems with it running in a sandbox and with OA being on. My other office applications, word, excel etc all work fine but I do not run in a sandbox.


    I never had to exclude SBIE when using OA. The only thing I have about sandboxie is setting it to "allow" in the program section and the firewall. I don't know if this is what you mean by exclude list.

    In my OA settings in Firewall>Restrictions I have everything set to Denied with nothing in the except for lists and sandboxie+firefox still work.

    Hope this helps in some way
  8. Seven64
    Online

    Seven64 Guest

    Reason I gave up on Online Armor, Iron will not connect using SBIE and OA.
    The only way I got Iron to connect was to put it in OA's exclude list, but what good is thato_O
    Windows 7, 64bit.
    I think you can eliminate AppGuard from the list.
  9. chris1341
    Offline

    chris1341 Registered Member

    Thanks for comfirming. I posted on the Emsisoft forum with no reply (although I see a reply has now been posted where they are unable to replicate my issues which I'll respond to) but from my own research it seems the OA fix was chrome specific not chromium browsers in general. :(

    I tweaked my SBIE settings and could get Outlook to work. Also resolved the Firefox issue but still had issues with other MS Office applications running Sandboxed and running apps for the first time causing lock-ups (OASIS look-up?).

    As I said no lack of alternativtes and Outpost 7.5.1 (and the 7.5.2 RC) working well with my other apps. It's a shame because I've used OA on and off since version 1 but unless Outpost throws a wobbly I'll probably stick with it going forward - needs a little more set-up and certainly chattier but much lighter and the x64 HIPS has really improved.

    Cheers
  10. Seven64
    Online

    Seven64 Guest

    It looks like it is fixed, at least Iron/SBIE in version 5.5.0.1545. Check updates in OA. If that don't work check the Beta update box in Options/general tab.
  11. chris1341
    Offline

    chris1341 Registered Member

    Thanks. I'm now having the update issue some users are having with 5.5 so can't check to see. I've been posting in their forum on this and they found the issue with Iron and said fixed soon yesterday. That's fast :D

    Now if they fix the MS Publisher and Foxit Reader sandboxed I'm good!

    Cheers
  12. Seven64
    Online

    Seven64 Guest

    Have you tried PDFXchange Viewer, Pretty nice piece of software.
    Plays well with OA.
    Don't use MS Pub so I cannot comment.
  13. chris1341
    Offline

    chris1341 Registered Member

    Got the update by resetting the registration. Confirm Iron issue fixed. Still have Publisher and Foxit issues. I'll keep Foxit meantime to see if they can work it out, if not maybe give PDFXchange Viewer a go

    Thanks
Thread Status:
Not open for further replies.