Notice for PG users who use the Block Rootkit\Driver Install feature

Discussion in 'ProcessGuard' started by Wayne - DiamondCS, Jun 9, 2005.

  1. ifty1
    Offline

    ifty1 Registered Member

    I don't have a reply to this thread but I presume this is the place where we discuss Process Guard. I have a Big Problem. I Forgot my Password to my ProcessGuard and just couldn't figure it out. Before I Locked it I checked the box beside where it says: don't allow new and changed applications from starting.... Then I locked it!! I tried and tried to remember my password and couldn't! So I uninstalled it manually because even Process Guard wouldn't let me uninstall it automatically. But my computer allowed me to take the name Process Guard out of the Add/Remove Programs(I was Surprized). Then I went into C:\Program Files\ProcessGuard and Deleted Almost All of the Files in there(it wouldn't let me Delete 2 of them) and the one on my Desktop and the Link to the original download. Now I tried to open and check almost All Software that I've downloaded and when I click on most things, it says(something like this) for example:
    You cannot open Spyware Blaster - This handle is invalid............... its a Miracle that I can still open and use my Registry Mechanic...THANK Goodness!! So can Anyone PLEASE let me know how I can Re-install ProcessGuard so I can have it working Again!! Do you know a way that I can Completely Uninstall it so I can Re-install it over again?? Any Help would Be Greatly Appreciated. Because I think I'll have to Completely Re-Boot my whole computer and I Don't want to Do that!!! :rolleyes: :oops:
  2. Gez
    Offline

    Gez Registered Member

    ifty1
    depending on your expertise this could be a bit complicated. First you need to reboot in Safe Mode with Command Prompt. You do this by pressing the F8 key at startup, after the initial POST screen comes up on your computer. You might need to press repeatedly.
    When you get into Safe Mode with Command Prompt you will see a black screen with something like c:\documents and settings\administrator.
    Type the following commands to delete the contents of your ProcessGuard folder and a ProcessGuard file in your System32 folder.

    cd c:\progra~1\proces~1\
    dir
    (Note -- If you see pgaaccount.exe and other stuff here it is safe to proceed. If not you could be in the wrong folder and don't proceed till you get further advice)
    del *.* /f /s /q
    (Note this will delete all files in your ProcessGuard folder and subfolders)
    cd c:\windows\system32
    del procguard.sys

    That's it. Hit Ctrl+Alt+Del keys to reboot normally, and reinstall PG.
    HTH

    Gez
  3. ifty1
    Offline

    ifty1 Registered Member

    I did what you said. I haven't been into Safe Mode for a few years, but I did it! I typed the above what you said and it seemed to work after I was out of Safe Mode, but things were not going well. Like freezing and things slowing down, then I got a Major virus and trojans on my computer so I Re-booted my whole System! Now Everything is Good. I even got to go into IE in Safe Mode and tried to fix it, but no matter what I did it just Wouldn't fix it. So now its pretty good. Thanks A Lot for everything. I Appreciate it!