NOD32 Interferes with MYSQL

Discussion in 'ESET NOD32 Antivirus' started by DreamU, Feb 14, 2012.

Thread Status:
Not open for further replies.
  1. DreamU

    DreamU Registered Member

    I am using xampp on Windows 7 using php against a mysql database. For certain queries, specifically a SHOW statement as opposed to SELECT, mysql returns a temporary file with the results which are processed by php. Unfortunately, NOD32 is grabbing that file and preventing mysql from deleting it. This all happens in a matter of millseconds: execute query, process results, delete temp file. The issue occurs about 50% of the time - when there is no issue I assume NOD32 did its 'thing' before mysql went to delete the file or after mysql finishes.

    I have confirmed NOD32 is the issue because if I disable NOD32, the problem goes away. ESET support said, "Open ESET, hit F5 to access the advaced setup, go to real time file system protection, click on setup, click on extensions, uncheck scan all files and click ok." Hence, I have told NOD32 to ignore these temporary mysql files (they have a .MYD and .MYI extension) everywhere I could. All to no avail - it simply will not ignore them (I have rebooted to be sure).

    I sent ESET the settings export file but I have received no further response from ESET in a week now. Does anybody on this forum have a suggestion?
  2. foneil

    foneil Eset Staff Account

    Can you PM me your case numer and I will check the status (bump) for you.
  3. DreamU

    DreamU Registered Member

    Thanks for your offer. The private message system is down so here is my case number: *
    Last edited by a moderator: Feb 22, 2012
  4. Marcos

    Marcos Eset Staff Account

  5. DreamU

    DreamU Registered Member

    Thank-you Marcos - very interesting!

    When I look at Process Monitor the process which is open/closing those .MYI and .MYD files (besides mysqld.exe) is SearchProtocolHost!

    If I disable that service the issue goes away. If I just disable indexing of the mysql folders the problem still persists (maybe I need to reboot after changing indexing?). So, I have turned off the service.

    Of-course, turning off NOD32 also made the problem go away. I don't know why that works but there is nothing in the log suggesting ekrn.exe is touching those files so I feel the problem is SearchProtocolHost.

    And, of-course, turning off Indexing is a lot safer than turning off NOD32!
  6. Marcos

    Marcos Eset Staff Account

    Thank you for letting us know, we're glad the issue's solved :)
Thread Status:
Not open for further replies.