NDIS usermode I/O driver

Discussion in 'other firewalls' started by eyespy, Jun 30, 2002.

Thread Status:
Not open for further replies.
  1. eyespy

    eyespy Registered Member

    Joined:
    Feb 20, 2002
    Posts:
    490
    Location:
    Oh Canada !!
    I'm now using Win XP and I have never seen so many apps trying to connect to the net !! Win98 was never this bad !
    I had to switch back over to Sygate PFW because ZA Plus just wouldn't run right on my PC.
    Anyway, when I log onto the internet, Sygate prompts me that "NDIS usermode I/O driver" is trying to connect to xxxxxxxxxx. It traces back to Yahoo or Yahoo chat.
    What the heck is "NDIS usermode I/O driver" ? Also, ZA plus never alerted me to that app !!
    Regards,
    bill o_O
     
  2. Paul Wilders

    Paul Wilders Administrator

    Joined:
    Jul 1, 2001
    Posts:
    12,472
    Location:
    The Netherlands
    eyespy,

    Prepare for some reading in regard to XP:

    www.3dspotlight.com/tweaks/winxp_services/
    www.blkviper.com/WinXP/servicecfg.htm
    www.overclockersclub.com/windowsxpservices.shtml
    www.techspot.com/tweaks/winxp_services/index.shtml

    Enjoy and succes!

    regards,

    paul
     
  3. eyespy

    eyespy Registered Member

    Joined:
    Feb 20, 2002
    Posts:
    490
    Location:
    Oh Canada !!
    Thanks Paul !
    while on the Firewall string, I might add that I could not uninstall ZA Plus completely after cleaning up reg keys and left over files. The left over files would not delete (4).
    I Found this neat link http://www.kellys-korner-xp.com/xp_tweaks.htm
    I discovered that I had to "disable" the XP Zip Association in order to delete these left over files !!
    I'm sure this will help a lot of people !!
    Here are the directions to disable/enable xp zip association:

    Zip Folders - To disable ZIP files being shown as folders

    Click Start/Run, enter the string below, and click OK: regsvr32 /u zipfldr.dll

    You should receive a dialog that says "DllUnregisterServer in zipfldr.dll succeeded." To restore the default behavior, simply do the same with this string: regsvr32 zipfldr.dll

    Tip: Stop Search from Scanning ZIP files: Un-register the zip and cab file dlls, then reregister them after that.

    Before Search:
    regsvr32 /u zipfldr.dll
    regsvr32 /u cabview.dll

    After Search:
    regsvr32 cabview.dll
    regsvr32 zipfldr.dll


    regards,
    bill ;)
     
  4. snapdragin

    snapdragin Administrator

    Joined:
    Feb 16, 2002
    Posts:
    8,415
    Location:
    Southern Ont., Canada
    Hi eyespy,

    i am also using XP-Home...and i get that NDIS usermode I/O driver wanting access to, and my firewall (Sygate) stops it to "ask" first, i read the details of the packet and mines for the i.band.tuner, which is this iM Radio Station Tuner/player that came with my pc....and starts up automatically when the pc starts. i've tried taking it out of startup, but then i get error messages, so i've had to leave the iM Radio Station Tuner/Player in the startup.

    i don't allow it access at all, so when the NDIS usermode I/O driver asks, i say no, and everything seems to work ok.

    the NDIS thing seems to ask on behalf of different programs though, because once in awhile it will come up as ask again, and i have no idea what program it's asking for, and now you are saying your's is tracing back to Yahoo chat?

    i'm with you on all these things wanting to connect and not knowing what they are or why they're wanting connection.

    Hi Paul! Thanks for those links! :)

    i've been reading several places on the net about XP but some of what what's access to the net seems to be specific to what a person has on their pc. it's a real struggle trying to figure out what's what and what wants to talk to what...or...whom?

    if i find out anything more here eyespy, i'll post back. :)

    (not quite awake yet) LOL
     
  5. snapdragin

    snapdragin Administrator

    Joined:
    Feb 16, 2002
    Posts:
    8,415
    Location:
    Southern Ont., Canada
    Oh! Bill, you mentioned that ZA wouldn't work on your system, and had to switch back to Sygate. i have Sygate Personal Firewall too, and i was trying out Look'n'Stop, but i couldn't get L&S to work either....it would detect my Adapter, but it wouldn't list anything as wanting to connect or ask for connection....it was as if i had no firewall on at all. So i had to go back to Sygate quickly.

    are you on cable with a router by any chance?

    i want to try L&S again...but i can't figure out why it wouldn't list anything as being connected or make anything ask. Sygate detected everything right away just with it's default settings. (i'm going to go to L&S's forum and see if anyone there had had the same problems)
     
  6. eyespy

    eyespy Registered Member

    Joined:
    Feb 20, 2002
    Posts:
    490
    Location:
    Oh Canada !!
    Thanks SD.
    I won't let it connect from this point forward ! ZA must let it connect by default, because I never received any alerts !
    BTW...that link of Paul's is great !!
    http://www.blkviper.com/WinXP/servicecfg.htm

    regards,
    bill ;)
     
  7. eyespy

    eyespy Registered Member

    Joined:
    Feb 20, 2002
    Posts:
    490
    Location:
    Oh Canada !!

    SD,
    i've never used L n'S ! I can't help you there my friend, but hopefully some of the other board members can help you out !
    It sounds like a strange problem though !! Could be a user setting. I'm wondering if the default settings were used in L n' S would it "ask all apps" before connecting !
    I'm using ADSL !! YEAH !!!

    good luck,
    bill
     
  8. puff-m-d

    puff-m-d Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    4,401
    Location:
    North Carolina, USA
    Snapdragin,

    I have cable with a router and have the same problem you are talking about (see thread here under firewalls - Look 'n' Stop and routers). I have also posted the question on the LnS forum over at Becky's and will let you know if I get the problem solved.

    Regards,
    Kent
     
  9. snapdragin

    snapdragin Administrator

    Joined:
    Feb 16, 2002
    Posts:
    8,415
    Location:
    Southern Ont., Canada
    Hi puff-m-d

    i was starting to think i was the only one here on cable with router/firewall using XP-Home LOL. i read your post at Becky's, and short of having someone actually sit down at my pc and figure how to get L&S to work, this is a li'l over my head! (ok, maybe ALOT!), so i will stay with Sygate for now. i like it alot and it seems to be stopping or making applicatons ask for anything that pops up, and it's working with no conflicts on my XP or my Win98se.

    i'll try L&S again, later, once i figure out a few more things on this system and better understand what's using what to call connect, then maybe i'll know why L&S didn't work for me.

    eyespy,
    i've been trying to find some layman terms for the NDIS thingie...and i'm still lost in it's relationship to what applications it's asking connection for.....it even popped up when i tried to open the page to this site...i had to scroll down and read the details in the packet to find what it why it popped up...and wilderssecurity with two ip numbers were listed there. i've only seen that happen once before; usually it pops up just for that iM Radio Tuner that i have never used and constantly block.

    but i did find a fairly descriptive site for NDIS FAQS:
    http://www.pcausa.com/resources/ndisfaq.htm

    maybe one of us will figure it out.....then tell the other in understandable non-techie terms...LOL
    :)
     
  10. puff-m-d

    puff-m-d Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    4,401
    Location:
    North Carolina, USA
    Snapdragin,

    Just for your info, Frederic has a patch that fixes the problems we both had. You can get it at http://looknstop.soft4ever.com/Tools/LnSRegPatch.exe

    It fixed all my problems. And once you solve this, L'n'S is very simple and easy to use. I know you have decided to stay with sygate for now, but I wanted you to know that a simple patch will fix your problem. Frederic does supply quick and good support for L'n'S.

    Regards,
    Kent
     
  11. snapdragin

    snapdragin Administrator

    Joined:
    Feb 16, 2002
    Posts:
    8,415
    Location:
    Southern Ont., Canada
    puff-m-d thank you!

    now how did you find that patch?? LOL

    i've bookmarked this thread because i will give Look&Stop another try, but i think right now i will stay with Sygate, i'm starting to get use to it enough i might try some rule-sets with it, but i must admit, the features in Look&Stop are VERY tempting!
     
  12. puff-m-d

    puff-m-d Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    4,401
    Location:
    North Carolina, USA
    Snapdragin,

    Over at Becky's on the L'n'S forum where I posted about my problem. Frederic, who is with L'n'S, solved my problem in a very quick manner. From what I have seen (and heard), Frederic supports L'n'S on the Becky's forum quite well (and yes, I am impressed with the prompt, excellent support that I have seen, and I am just test driving at the moment :D ).

    Regards,
    Kent
     
Thread Status:
Not open for further replies.