Mounting Ext4 without "noowners"

Discussion in 'NTFS for Mac & ExtFS for Mac' started by gomi, Jun 5, 2013.

Thread Status:
Not open for further replies.
  1. gomi

    gomi Registered Member

    Jun 5, 2013
    By the way of explanation my MBP dual boots between Lion and Linux. I have 300GB ext4 shared physical partition, additionally I have a number of project specific truecrypts volumes all formated to ext4.

    Previously I've used hfsplus without journalling. I have normallised the uid/gids between Lion and Linux as that makes life easier when running an NFS and sharing files in the common areas.

    I've noticed the Paragon's ExtFS driver appears to always mount Ext4 with the noowners option, e.g.:

    /dev/disk1s3 on /Volumes/data (ufsd_ExtFS, local, noowners)

    I am unable to remount, umount/mount the partition without noowners. I would like my user accounts and services to honour the permissions I have setup.

    Is this a bug, a deliberate design feature or is there a way?

    Thanks in advance
Thread Status:
Not open for further replies.