Manipulate ACE from pre-processing command

Discussion in 'Acronis True Image Product Line' started by chrizio, Dec 3, 2008.

Thread Status:
Not open for further replies.
  1. chrizio

    chrizio Guest

    ATI 9.0 Home

    Dedicated logic disc for all images created by ATI.
    All known users have read-only access rights for this disc.
    For the duration of ATI imaging process "change" access rights are granted for this disc to user-defined administrator.
    Read-only rights retrieved after imaging completed.
    All those operations are made using setACL application.
    Called from batch file invoked by pre-processing command.

    However setACL returns errors
    ERROR: Reading the SD from <\\?\UNC\KRZYDU-PC01\Z$> failed with: The data area passed to a system call is too small.
    SetACL error message: A privilege could not be enabled

    Does setACL have sufficient access rights to complete its job ?
    I guess, scheduled tasks run from SYSTEM account.
    At least the Task Manager is claiming that.

    setACL experts say SE_SECURITY_NAME must be enabled for
    process executing this operation.
    How can I ensure setACL has sufficient rights when running
    in context of scheduled task ?
  2. chrizio

    chrizio Guest

    Well, my questions then in other words.

    1. Why is the pre-processing command unable to change access rights
    of a logical disc ACES (using calcs or setACL) ?
    2. What rights are granted to the scheduled tasks, Administrotor, System,
    Limited- User ?
    3. How can I help the scheduled task to be able to change access rights
    to the logical disc ?
  3. Acronis Support

    Acronis Support Acronis Support Staff

    Apr 28, 2004
    Hello chrizio,

    Thank you for your interesting in Acronis True Image

    The program requires Windows authorization for a scheduled task execution. That is why you should enter your account name and password both to let Acronis True Image program log in Windows with Administrator's rights and execute a scheduled task. The user name should be specified in the form of SERVER\USER or DOMAIN\USER.

    If the issue persists submit technical request using this link

    Best regards,
    Dmitry Nikolaev
Thread Status:
Not open for further replies.