Introducing AX64 Time Machine - hybrid imaging/snapshot software

Discussion in 'backup, imaging & disk mgmt' started by Isso, Jan 18, 2013.

  1. manolito
    Offline

    manolito Registered Member


    Hi Adric,

    problems with the bootable media may occur if the media have been created under Win XP. Isso uses some clever tricks to make WinPE boot media without requiring that the user downloads the WAIK. AXTM uses the WinRE.wim which is included in every Win7 installation. Under Vista the Vista installation CD is required to access the WinRE.wim, but under XP Isso uses some other undocumented tricks that I do not understand...o_O

    The boot media (USB stick or CD) made under Win XP may or may not work to start the computer. It worked with one of my notebooks, but not with the other one.

    My conclusion is that currently you should try to create boot media under Win 7 by all means. These bootable media had no problem booting 3 different machines I have access to...


    Cheers
    manolito
  2. Adric
    Online

    Adric Registered Member

    Ok, I managed to boot the XP iso by changing the boot.ini default to what the
    boot prompt was asking for. In my case it was 'A0', which was not part of the
    original selections. It got as far as the CD did and ended with the same 7b
    crash. I'm sure this can be fixed with the right driver installed in the iso.

    I also went and created a Win7 iso and booting it was not a problem. The
    AX64 Recovery Environment automatically found my test backup and the test
    snapshot I had done 5 minutes later. AX64 even let me create the iso from W7
    without me having to install it. I just ran the gui in W7 from where it was installed on XP.


    Thanks, Al
    Last edited: May 4, 2013
  3. Isso
    Offline

    Isso Developer

    atomomega,

    Thank you for suggestion. Frankly I haven't been thinking about lifetime licenses, I'll give it a thought. Not sure it'll be properly supported by the current licensing module.
    By the way this leads me to another idea - to offer those beta-testers who spent significant time testing the software a free lifetime license as an appreciation for their great help.

    Isso
  4. Isso
    Offline

    Isso Developer

    umbrapolaris,

    I too noticed this happening sometimes, but it was so rare that I wasn't able to properly debug it. Please just leave it when it hangs - it should complete the restore and reboot. Otherwise if you reset the system the partition may become corrupted, and the only way to recover will remain the Recovery media.

    We will fix this issue in one of the upcoming releases.

    Isso
  5. Isso
    Offline

    Isso Developer

    bgoodman,

    I'll be thinking about that option too. The proper approach IMHO is to have a forum on the official site. But I agree with you and I'm too used to Wilders.

    bgoodman, Balders, twl845, MarcP and others who kindly refused my offer - guys, I really appreciate it, but what makes me feel quite uncomfortable is following:

    you are among the ones who helped me the most, and spent really lot of time on this forum making AXTM better. So it's quite unfair for you to pay for the product, and for the others to receive it for free.
    Again, guys if you accept the offer I'll personally will be feeling happy and less obligated. If you decline it and pay - that money won't really be changing anything. If you only knew how much money I've spent for the development during last 2 years...
  6. Fad
    Offline

    Fad Registered Member

    Maybe allow an optional voluntary donation in exchange for the free license - then everyone`s happy :)

    It might not amount to a great deal in the bigger picture, but I`m sure a lot would like to show their appreciation in this way.
  7. The Shadow
    Offline

    The Shadow Registered Member

    Isso,

    I have tried a few times (unsuccessfully) to create recovery media! Those attempts have actually resulted in 3 'CD-coasters' (from each of the past 3 beta releases that I have installed). I can tell you that the resulting iso-file does not contain the Intel RST drivers.

    Regards,
    TS
  8. Fad
    Offline

    Fad Registered Member

    I won`t pretend to know what the problem is with these missing driver issues as I can`t even recall what was on the previous page of this thread nevermind any further back...

    but I was just wondering if the issue is somehow similar to my problem regarding the USB3 drivers - I had to manually insert them into the winre file.

    I can`t recall the exact reason it didn`t work, but I think it was something to with the fact that they weren`t native drivers and were 3rd party (this mobo came with a PCI USB3 card when I bought it) and the drivers simply weren`t being picked up.

    It`s all right over my head unfortunately - but just wondered if it was a similar situation ?
  9. Isso
    Offline

    Isso Developer

    Hi gimmeagig, and welcome! I recommend (as with any other backup software) to test your setup first. I.e. try to do a backup and a restore to make sure everything works. Then you might want to choose between manual and automatic backup options - whatever suits you better.

    Isso
  10. Isso
    Offline

    Isso Developer

    Fad,

    Could you please share the method that you used to manually insert drivers into Winre? That might solve the RST problem too. Thank you

    Isso
  11. Isso
    Offline

    Isso Developer

    Fad, this is another thing that a lot of people are interested in. Perhaps you could even open a new thread and describe these two topics (injecting drivers into WinRe and adding recovery environment to boot menu) there. Thank you

    Isso
  12. Fad
    Offline

    Fad Registered Member

    Well, it was really quite a drama as it turns out...after a couple of days of trying to figure out what the problem actually was and tesing this, that and the other (I was trying to get other, different WinPE ISOs to work as well...so confusing matters even further..)

    In the end I found this little tool which I used to mount the standard Win 7 WinRE file and within it, it allows you to load drivers...on the "Driver management" tab - it`s quite simple to use once you have the correct drivers :rolleyes: :D

    of course, I had the problems with not having the correct 32bit USB drivers as I only got the x64 bit ones installed here...but several different driver packs later I found suitable ones.

    The program I used is DISM GUI found here: http://mikecel79.wordpress.com/

    I then placed my modified winre file into the "Recovery" folder on the boot drive - which I had to create as I didn`t have Recovery installed, but AX found the file and created the boot/recovery ISO and all worked just fine after that.
  13. Isso
    Offline

    Isso Developer

    Hi Al,

    Thank you for the information. For higher DPI support - will implement it in one of the upcoming versions.

    For "Make backup now" button behavior - completely agree, will add it.

    For full backup - the reason is that AXTM is primarily a backup/imaging program, thus it makes a copy of all the data in order to recover it if the drive fails. Snapshot programs don't have that ability.
    What makes AXTM similar to snapshot programs is primarily its speed and ease of "traveling" between snapshots. Otherwise it's a normal backup/imaging solution.

    For command line window - the program is doing a very tricky operation of restoring the drive while OS is running. We noticed some compatibility problems with running GUI program and restore process. That's why we replaced it with console window. As Froggie mentioned the look of that screen doesn't really matter, because the PC is effectively locked during restore. But we are going to solve this problem and replace console back with GUI.

    For XP recovery CD - there is a problem that the disc identifier (9F, EF etc) is system specific and cannot be determined until the system is booted. That's why after the recovery CD is booted you'll see the identifier on the screen - you just need to select that identifier on the boot selection menu. Yes, this is a bit odd, but we found no other way to get XP recovery CD version working.

    For GRUB - I'm not sure if it can be used, sorry. My guess is it can, but I haven't tried it.

    For 7B stop - looks like some drivers weren't copied to the disk, could you please upload the ISO file somewhere and send to me the link (info@ax64.com). Thank you

    Isso
  14. Wendi
    Offline

    Wendi Registered Member

    Hi Isso,

    This is to share my recovery-media results (as you requested). With the current (.967) beta version installed I selected 'Create Recovery Media' and proceeded to create a Recovery CD. It complete successfully, so I then booted my system with that CD. The CD seemed to have booted successfully but does not present my hard drive under 'Computer'!!! The only items listed under 'Computer' are the CD Drive [D:] PE Builder and Boot [X:]. :doubt:

    Isso, a while back you suggested simply including the necessary AXTM files on one's own boot media, but (for whatever reason) it did not work. If that method could be resolved, I would consider that an even better boot-recovery solution, because that way the same boot media could be used for multiple PCs.

    Wendi
  15. Isso
    Offline

    Isso Developer

    smith,

    I'll look into it, thank you.

    Isso
  16. Isso
    Offline

    Isso Developer

    manolito,

    You are totally correct, the main idea was to create the recovery CD without requiring any third party file like WAIK etc. And while for Vista and 7 it was easy, for XP this turned out to be a very tough task. We solved it, but XP by itself has lot of limitations that result in recovery media sometimes refusing to properly work. Win Vista, 7, 8 - based media is much more flexible and complete.
    So I agree - if you have a OS newer than XP you can always use the media that you created on it.

    Isso
  17. Isso
    Offline

    Isso Developer

    Hi Wendi

    Looks like indeed a problem with storage drivers. We'll try to solve it as soon as possible. For including the program into other boot media - we'll solve this too.

    Isso
  18. Fad
    Offline

    Fad Registered Member

    I don`t know if this is anything to do with Grub....

    but I`m multi booting the AX64 ISO from a flash drive successfully using YUMI ( "YUMI uses Syslinux directly, and chainloads to grub only if necessary" )

    http://www.pendrivelinux.com/yumi-multiboot-usb-creator/

    if that helps any ?

    It`s so easy to use I didn`t even get a headache when I tried it. :thumb:
  19. djg05
    Offline

    djg05 Registered Member

    Hallo Isso

    I have been playing with it a bit more today and have few comments to make.

    I do not have it on auto backup and it is 2 days since the first backup. I went to make another backup of the system drive and assumed that it would append to the original, but instead it made another complete backup. It used the same partition/folder as before. Maybe I have missed something but can't see anything obvious.

    When this happened there was no 'Cancel' button to stop the process. Can one be added?

    I then created a recovery using a USB stick. That was ok but I would prefer to use a USB hard disk.

    The USB stick booted ok using F8 before Win starts (Win 7/64). I do like the PE interface - very neat and clear.

    I started the restore and noticed during it that the MBR option was selected. I didn't want that so deselected that - surely that should not be possible during a restore?

    Other than that the restore completed without problem.
  20. Wendi
    Offline

    Wendi Registered Member

    Isso, that truly would be awesome. Other than the missing Intel RST drivers in the recovery-media I am thrilled with AX64TM. So far I haven't found anything else that hasn't worked - and twice as fast as Drive Snapshot, the disk-imaging program I've been using for several years! :thumb:

    Wendi
  21. pandlouk
    Offline

    pandlouk Registered Member

    Oh boy, I didn't come in the forum for 2 weeks and the thread became enormous. I only read the last two pages and I'm happy to see that a stable release is near. Congrats!

    Isso, Ax64 works in virtualbox enviroment? I tried to install it two days a go on a friends Virtual XP to show him what a fine tool it is and it gave me an error when I executed it (everytime it crashed during execution).

    About your question on how to inject drivers in winpe enviroment it is very easy with dism. Some examples.
    http://technet.microsoft.com/en-us/library/hh825125.aspx#BKMK_AddDrivers
    http://technet.microsoft.com/en-us/library/dd744355(v=ws.10).aspx
    http://blog.uvm.edu/jgm/2010/08/17/adding-drivers-to-the-built-in-windows-recovery-environment/

    And I also have a feature request. Since Ax64 uses VSS can you add an option or a standalone app to exclude files folders from imaging? (Currently I do it manually by modifying the registry)
    http://msdn.microsoft.com/en-us/library/windows/desktop/bb891959(v=vs.85).aspx
    http://msdn.microsoft.com/en-us/library/windows/desktop/aa819132(v=vs.85).aspx

    thanks,
    Panagiotis
  22. djg05
    Offline

    djg05 Registered Member

    Hello Isso

    After posting my last message to you it all went wrong.

    I rebooted to check something out and it would not shutdown - got stuck at the shutdown screen. Left it for around 10 minutes. Did a hard reset and it would not boot - got stuck at the Windows logo (win 7/64). Then did a cold boot and same result.

    Have now reverted to an image prior to installing AXTM.

    The point at which it seemed to go wrong was when I loaded the 'Build Recovery Screen'. I had the USB stick inserted and changed my mind and cancelled the screen. After that I could not read or eject the stick. The other USB drives I have could not be recognised when switched on.

    Loading Windows Disk Management took forever to load and again could not see the external drives.

    Before installing again I will await your advice on what and how to test.
  23. Baldrick
    Offline

    Baldrick Registered Member

    Hi Fad

    That sounds like a plan...and nicely equitable in the scheme of things.

    :thumb:
  24. pandlouk
    Offline

    pandlouk Registered Member

    Donation is not good for me.
    Isso has said that he will give a free license to those that helped him as an appreciation of that help. Plus a discount to wilders members. So from my point of view anyone who gets a free license and wants to help him can buy another one and give it to a close relative or a friend.

    This way those that receive a free one will be happy, their friend that gets the gifted license will be happy and Isso will be happier since his customer/client base will increase.:D

    Panagiotis
  25. mrfargoreed
    Offline

    mrfargoreed Registered Member

    Hi Isso

    This latest version (1.0.967) seems much more stable on my system (Windows 8 64bit). Plenty of backups and restores and so far, not a single problem to report. Really, really like this software :thumb: - great work, thanks.