How to Enable PREFETCH in XP?

Discussion in 'other software & services' started by Birdman, Aug 31, 2006.

Thread Status:
Not open for further replies.
  1. Birdman

    Birdman Registered Member

    Joined:
    Nov 24, 2003
    Posts:
    566
    I just noticed the other day that my Prefetch folder is completely EMPTY, thus causing system slowdown on start-up. I need to re-enable this feature. I checked in the registry:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters]

    "EnablePrefetcher"

    It was set to the recommended "3" value. I recently disabled a few XP Services from starting up on my pc and I believe that's where the problem lies.

    Can someone please tell me what, if any, services are NEEDED to start for Prefetching to properly work in Xp?

    Thanks.
     
  2. Stem

    Stem Firewall Expert

    Joined:
    Oct 5, 2005
    Posts:
    4,948
    Location:
    UK
    Is the "Task scheduler" service enabled?
     
  3. NICK ADSL UK

    NICK ADSL UK Administrator

    Joined:
    May 13, 2003
    Posts:
    9,134
    Location:
    UK
    And if i may add be sure to make sure that the logical disk manager is started and on automatic. Also the event log!
     

    Attached Files:

  4. Birdman

    Birdman Registered Member

    Joined:
    Nov 24, 2003
    Posts:
    566
    Stem and NICK ADSL UK.......thank you very much for your help. I finally got it working. I had BOTH Task Scheduler and LDM services disabled. I enabled them both (set to auto) and prefetch is now working again. :)
     
Thread Status:
Not open for further replies.