How to enable autoplay

Discussion in 'other software & services' started by Atomas31, Feb 6, 2012.

Thread Status:
Not open for further replies.
  1. Atomas31
    Offline

    Atomas31 Registered Member

    Hi,

    I'd like to enable autoplay for removable drives on my windows XP (home) with SP3 but with no luck! I tried with Tweak UI but that didn't work either...

    What could be the problem and how can I solved this issue?

    Thanks,
  2. HAN
    Offline

    HAN Registered Member

    Is it autoplay (or autorun) that was disabled by design from Microsoft? MS patches that came over the last couple of years or so??

    Personally I turn off everything related to autoplay/autorun. Just too big of a security risk...


    Related to your issue?? http://support.microsoft.com/kb/967715
  3. ABee
    Offline

    ABee Registered Member

    Go to 'My Computer', right-click on the drive, choose 'Properties', then the 'Autoplay' tab.
    Make your choices, then 'Apply'.
  4. Atomas31
    Offline

    Atomas31 Registered Member

    @Han, my system being up to date that must explain why my autoplay/autorun doesn't works... Thank's for your link, I'll try that ;)

    @Abee, I don't have a tab "Autoplay"?
  5. ABee
    Offline

    ABee Registered Member

    On what drive? You have one for your CD or DVD drive, right?
  6. MerleOne
    Offline

    MerleOne Registered Member

    I had such an issue a while ago, I solved it using SysCheckup (seeon http://www.tipradar.com/giveaway-syscheckup-full-version-licenses.html).

    I also found that is was the same trick as the one shown on Wikipedia :

    http://en.wikipedia.org/wiki/AutoRun :

    [
    As an autorun.inf file is a standard Windows INI file, the appropriate API calls are used by Windows when fetching its settings. These API calls can be redirected using the INI file mapping method. The following Registry file illustrates the workaround, where all autorun.inf settings are taken solely from the HKEY_LOCAL_MACHINE\Software\DoesNotExist Registry key:Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\Autorun.inf]
    @="@SYS:DoesNotExist"
    ]

    Hope this helps.
  7. Atomas31
    Offline

    Atomas31 Registered Member

    @Abee, yes, you are right I have this tab for my DVD/cd drive :oops:

    @MerleOne, your link for syscheckup is broken... I find it anyway and it is a good little apps! This software combine with TweakUI finally solve my issue :D

    Thanks everyone for your helps :) :thumb:
  8. MerleOne
    Offline

    MerleOne Registered Member

    Sorry for the broken linik : just remove the last character, a parenthesis, and it will work.
Thread Status:
Not open for further replies.