Help to setup Mullved VPN-OpenVPN on Linux Mint KDE?

Discussion in 'privacy problems' started by Warlockz, Mar 25, 2012.

Thread Status:
Not open for further replies.
  1. Warlockz
    Offline

    Warlockz Registered Member

    OK so Im trying to setup Mullved VPN on Linux Mint 12 KDE and I did as it said in the Mullved OpenVPN Instructions.

    So Now what do I do? I am clueless and /etc/init.d/openvpn start seemed to start somthing but now what do I do to connect? I dont understand?

    I am using a wireless connection.
  2. mirimir
    Offline

    mirimir Registered Member

    If the openvpn demon started OK, you should be connected. You can check whether it's running by typing "ps -C openvpn". If it's running, open your browser and visit one of the many IP check sites to verify that you're connected. If it's not running, check group and owner settings for the files from Mullvad. They should be root, not your user account. Also, the extension of the configuration file should be "conf", not "ovpn". Then restart the openvpn demon. Finally, install shorewall and configure it for securing the VPN connection per instructions that you'll find on Wilders.
  3. PaulyDefran
    Offline

    PaulyDefran Registered Member

    Just an FYI: Their .deb installer is just a wrapper for OpenVPN with some options (block connection on VPN drop and exclude Swedish traffic). I used it on Ubuntu without a hitch. Just an option if you have trouble with OpenVPN proper.

    PD
  4. Warlockz
    Offline

    Warlockz Registered Member


    When I do "ps -C openvpn" it gives me "PID TTY TIME CMD" Do you know what this means?

    Here is a run around to get a better picture of whats going on
    so is "kill: 283: No such process" what does this mean? looks like Im missing somthing?

    PS: My regular Internet connection without any VPN ect on Linux Mint 12 KDE is always like a rollercoaster sometimes? Up and Down for some reason on occasion even on both wireless and wired connection? I tried both one at a time and both do the same thing, sometimes it crawls so slow webpages timeout? and I have a 20+mbps connection, but its always cutting out on me?


    Update EDIT: I seem to have corrected my Internet Issues By installing the Right Realtek Driver, bu following this tutorial, but VPN still not working!

    Sorry about my Linux Newbness o_O
    Ownership for Owner and user is Root :thumb:
    Last edited: Mar 25, 2012
  5. mirimir
    Offline

    mirimir Registered Member

    That tells you that the openvpn demon didn't really start.

    That also tells you that the openvpn demon didn't really start. Asking the openvpn demon to restart first tells it to stop, and "No such process" tells you that it wasn't running.

    Please list the /etc/openvpn folder (ls -l /etc/openvpn) and report the output. I've seen the behavior that you've reported when the openvpn config file (here "mullvad_linux.conf") doesn't belong to root.
  6. Warlockz
    Offline

    Warlockz Registered Member

    does Mullvad VPN still let users use their service for free when they use Open VPN? Just wanted to be sure?
    Last edited: Mar 26, 2012
  7. Warlockz
    Offline

    Warlockz Registered Member

    Sorry I replied right after you replied without reading your last reply, must have replied around the same time lol


    ~ # ls -l /etc/openvpn
    total 36
    -rw-r--r-- 1 root root 6296 2009-06-12 00:52 ca.crt
    -rw-r--r-- 1 root root 6296 2009-06-12 00:52 master.mullvad.net.crt
    -rw-r--r-- 1 root root 4906 2012-03-25 01:58 mullvad.crt
    -rw-r--r-- 1 root root 1675 2012-03-25 01:58 mullvad.key
    -rw-r--r-- 1 root root 1143 2011-03-15 14:18 mullvad_linux.conf
    -rwxr-xr-x 1 root root 1357 2011-07-04 07:10 update-resolv-conf
    Last edited: Mar 26, 2012
  8. mirimir
    Offline

    mirimir Registered Member

    Look in /var/log/syslog to see what happened. Old syslogs become syslog.n.gz
  9. Warlockz
    Offline

    Warlockz Registered Member

    I had to recreate the problem sense I played around with BleachBit looks like the old logs are gone.
    here is the log
    View attachment syslog.txt
  10. mirimir
    Offline

    mirimir Registered Member

    You connected, but authorization failed. Maybe they no longer allow free access using OpenVPN. Anyone know?

    Code:
    ...mr-x ovpn-mullvad_linux[1573]: [m5.mullvad.net] Peer Connection Initiated with [AF_INET]...:1194
    ...mr-x ovpn-mullvad_linux[1573]: SENT CONTROL [m5.mullvad.net]: 'PUSH_REQUEST' (status=1)
    ...mr-x ovpn-mullvad_linux[1573]: AUTH: Received AUTH_FAILED control message
    ...mr-x ovpn-mullvad_linux[1573]: TCP/UDP: Closing socket
    ...mr-x ovpn-mullvad_linux[1573]: SIGTERM[soft,auth-failure] received, process exiting
    
  11. PaulyDefran
    Offline

    PaulyDefran Registered Member

    Getting connected for free was always hit or miss. There were a few .ovpn setups posted in the other thread that may work...I long since got rid of them since I became a customer. I think a month is $7 and IIRC using their client gets you 3 hours on a new install. No idea if you get the 3 hours with OpenVPN proper. They respond to emails to admin@

    PD
Thread Status:
Not open for further replies.