Happy Grub 2 and Lucid user.

Discussion in 'all things UNIX' started by Ocky, May 17, 2010.

Thread Status:
Not open for further replies.
  1. Ocky

    Ocky Registered Member

    May 6, 2006
    George, S.Africa
    I made these simple changes to my Lucid Grub 2 bootloader and am now a very happy Ubuntu dual booter. i mainly wanted to see the splash image I had for Karmic plus a descriptive boot menu entry. This is of course not possible when using the OS prober, which I disabled for good measure. Bootable rescue CD works fine as usual.
    (..Karmic is on my second SATA drive i.e. sdb with Grub installed to / partition boot sector, hence (hd1,1) ....)

    Changes made to Lucid (17-5-2010)

    In /etc/grub.d 40_custom added:

    echo "Adding custom boot entry(s)" >&2 (Edit: Not needed)
    cat << EOF
    menuentry "Ubuntu Karmic 9.10" {
    set root=(hd1,1)
    chainloader +1


    Add to etc/default/grub


    and.. (Edit: If you have this situation:- Bootup/Plymouth.
    Users should experience a much faster boot however some users may experience problems with Plymouth after the nVidia graphics driver has been enabled. Users may experience plymouth using lower graphics resolution.)

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXPAYLOAD_LINUX=1440x900 ****

    Save the file and run sudo update-grub

    **** I added this line. (Should be your monitors native resolution)

    For Windows/Ubuntu dual booters this seems to be the way to go nowadays:-

    Last edited: May 18, 2010
Thread Status:
Not open for further replies.