Eset Nod32 Antivirus 4 Problem With Cisco AnyConnect VPN Client

Discussion in 'ESET NOD32 Antivirus' started by aakash, Jan 12, 2010.

Thread Status:
Not open for further replies.
  1. aakash
    Offline

    aakash Registered Member

    I have been having problems using the Cisco AnyConnect VPN client on my computer where I experience lags when I remote desktop my work computer. Text only displays about 1-2 seconds after I type it.

    I am using Eset Nod32 v4.0.474.0 on Windows 7 Ultimate 64bit with the Cisco AnyConnect client v2.4.0202.

    After disabling the Eset Service, the problem went away.

    I then followed user Gan's advice at http://www.wilderssecurity.com/showpost.php?p=1360776&postcount=16 and found that checking "Do not use HTTPs protocol checking" resolved the problem.

    Adding exclusions to both the VPN installation file path and adding the VPN addresses into the "HTTP, HTTPS" address management exclusions did not help the situation either.

    Please correct this as soon as possible so that we may successfully use Eset Nod32 v4 when connecting to work using the Cisco AnyConnect client.

    If you need any other information from me, please let me know.

    Thanks.
  2. GAN
    Offline

    GAN Registered Member

    I reported this problem December 2008 as you can see and still not fixed so i wouldn't expect a quick fix for this problem. The only solution is to disable SSL scanning like you already did since it will slow down SSL a lot in general when enabled. Not sure if Eset have done any changes in the new beta, but might be worth checking.
  3. aakash
    Offline

    aakash Registered Member

    GAN: That's true. Hopefully Eset is able to start working on this soon since the AnyConnect client is the only Cisco VPN software that is supported on 64bit clients.

    Eset: To add to my initial note, I also wanted to point out some other problems I encountered that made pinpointing Nod32 as the culprit even harder:
    1. Even if I temporarily disabled Nod32's security modules, access to the VPN was still very slow. It was only after disabling Eset service via Safe Mode that I was able to pinpoint Nod32 as the problem. When a user temporarily disabled Nod32, I expect ALL Nod32 services to cease until I restart them.
    2. The problem did not exhibit itself while using VirtualBox on the same. So, connections to the VPN from virtual Win7 x64 machines worked without any delays. So, it appears that third party programs are able to bypass the SSL security. In my case, this turned out to help me since it helped me determine the problem sooner.
  4. goran_larsson
    Offline

    goran_larsson Registered Member

    I think it may be awhile before this is resolved, I have had little or no luck on getting any attention to this issue for some time now.

    /Göran
  5. MOM2009
    Offline

    MOM2009 Registered Member

    the same problem here with watchguards mobile ssl vpn (openvpn based).

    so eset please fix this.
  6. valnar
    Offline

    valnar Registered Member

    This problem, and this problem alone made me leave NOD32. They've lost a customer awhile ago.

    I hope ESET is reading this. Of course at this point, I may never come back anyway.
  7. gdonlon
    Offline

    gdonlon Registered Member

    I had the same issue as well on a Firebox appliance. For the time being I changed the port from 443 to 444 so that ESET wouldn't slow things down.

    That appeared to fix my issue for our clients. The nice part about the watchguard is it will download a new policy with the new settings to the client on the first connect as well so it was a pretty painless process. That said, it would be nice to have a fix for these types of things.
  8. MOM2009
    Offline

    MOM2009 Registered Member

    thank you eset. the newest 4.2.40.10 fixed my watchguard vpn issues.
Thread Status:
Not open for further replies.