Eset 4.2.64 BSOD with Truecrypt

Discussion in 'ESET NOD32 Antivirus' started by nurgle, Aug 23, 2010.

Thread Status:
Not open for further replies.
  1. kanbol

    kanbol Registered Member

    Joined:
    Oct 4, 2011
    Posts:
    4
    hello,please pm me the new sys file for 4.2 (Win7 - 64bit)
    thanks
     
    Last edited: Oct 4, 2011
  2. cabox

    cabox Registered Member

    Joined:
    Oct 6, 2011
    Posts:
    1
    Same issue here with 4.2.71, BSODs when mouting a Truecrypt volume on external hard drive (at least one of them was in fastfat.sys)

    I tried v5, but uninstalled it again because since I installed it I had an extremely long login phase (couple of minutes after entering the login data on an i7 quad core with SSD on Win7/x64, default installation location)

    So at this point, I'd like to request the fixed drivers for v4.

    Thanks,
    cabox
     
  3. kanbol

    kanbol Registered Member

    Joined:
    Oct 4, 2011
    Posts:
    4
    anybody help me ?
    where can i get the new sys file?thank you
     
  4. ohrats

    ohrats Registered Member

    Joined:
    May 2, 2009
    Posts:
    3
    I had ESS 4.2.71.2 using Truecrypt 6.1 and never experienced any problems. A few days ago I moved to ESS 5, after which the system hung whenever trying to mount a Truecrypt volume. I tried many fixes without success other than going back to 4.2.71.2. I contacted ESET UK support who sent me the eamon.sys file (as part of a 'USB Fix' bundle). Trucrypt now mounts, albeit slowly, however my PC crashes frequently for no apparent reason when Truecrypt is not mounted nor running as a service in the background, in fact it crashes with Truecrypt software completely uninstalled! Sometimes it simply reboots itself, or boots and then reboots automatically. This new problem must be caused by the ESS 'fix', which is no doubt why it is not officially part of ESS or NOD.

    This whole issue has been going on for well over a year, and ESET have done nothing to address it. The only conclusion possible is that they aren't bothered about the small number of people using Truecrypt and ESS/NOD, but that's a complete denial that something is amiss with their product. I've now started looking at alternatives to ESET. Unfortunately I have 1.5 years left on my ESET licences ... money well wasted by the looks of things.

    Any suggestions as to what to replace ESS with? Preferably something with a configurable firewall and low footprint on the system.
     
  5. rekun

    rekun Registered Member

    Joined:
    Jun 11, 2007
    Posts:
    89
    @ohrats

    Please try the new update for v5 - 5.0.94

    I have seen otherwhere that it should include fixes for truecrypt
     
  6. ohrats

    ohrats Registered Member

    Joined:
    May 2, 2009
    Posts:
    3
    Thanks Rekun, but I did try 5.0.94.

    I just had a call from an old colleague who saw my post, he suggested mounting the Truecrypt volume as 'removable media' (an option under SETTINGS/PREFERENCES). I did clean installs of both, and so far one PC is stable under 5.0.94, also the Truecrypt volume mounts instantly, I'll try the other PC later. I have defintely not used the replacement eamon.sys which seems flakey. Somehow I suspect this solution won't work with those using whole Truecrypt drives or partitions, but 'appears' to work for me ... so far.
     
  7. polymathic

    polymathic Registered Member

    Joined:
    Oct 25, 2011
    Posts:
    1
    I am running Windows 7 64bit with tc7.1 and eset AV version 4.2.71.2, and I am also getting BSOD. Can you please pm the fix file and instructions on how/where to install? thank you,
     
  8. ottchris

    ottchris Registered Member

    Joined:
    Nov 10, 2007
    Posts:
    3
    A few months ago I upgraded from XP Pro 32 bit to a new machine running Win 7 Pro SP1 64 bit and immediately experienced the BSODs. Can't recall what versions of TC/ESET I was running but they would have been the latest at the time. A few weeks ago (having revisited this thread) I created a new TC container file using the latest versions of TC/ESET and no more BSODs. NB there was conflicting information on whether version 5 could be installed over version 4 so I contacted Eset for clarification. They replied that installing 5 over 4 should be OK but they recommended uninstalling 4 first which I did. Re another reply I have not altered any TC settings i.e. removal media box is not ticked. The app versions are TC 7.1 and ESET NOD 32 AV (64bit) 5.0.93.0. The TC file container is on the C: partition and is mounted as a Z: partition.

    Regards to All,

    Chris
     
    Last edited: Oct 30, 2011
  9. ohrats

    ohrats Registered Member

    Joined:
    May 2, 2009
    Posts:
    3
    Chris. OK, tried all that just now, but failed for me (clean installs of both, 5.0.94 and 7.1). No BSOD, but system hanging when trying to mount unless the removable box is ticked in TC (I only ever had BSOD when using the replacement eamon.sys). Only tried on an XP32 Home machine. Will try Win7 later.
     
  10. glenon

    glenon Registered Member

    Joined:
    Nov 3, 2011
    Posts:
    1
    @Marcos could you please send me the replacement sys file?

    Thank You!!
     
  11. Kroduk

    Kroduk Registered Member

    Joined:
    Apr 24, 2009
    Posts:
    2
    Hi Marcos,

    Can you send me the replacement sys file too?

    Thanks!
     
  12. shadowreaper

    shadowreaper Registered Member

    Joined:
    Nov 24, 2011
    Posts:
    1
    Location:
    Canada
    Hi Marcos,

    Can you send me a link also? Doing a rollout of Windows 7 to 250 computers which use truecrypt every day.

    Thanks
     
  13. kanbol

    kanbol Registered Member

    Joined:
    Oct 4, 2011
    Posts:
    4
    Hi Marcos

    could you please send me the replacement sys file?

    Thank you!
     
  14. kanbol

    kanbol Registered Member

    Joined:
    Oct 4, 2011
    Posts:
    4
    does 4.2.76 fix this issue?
     
  15. Enigm

    Enigm Registered Member

    Joined:
    Dec 11, 2008
    Posts:
    188
    It's not exactly the first time this is a problem .
    If you STILL can't get it right.. What else can't you do right ??
    Seriously, you repeatedly break the functionality of a pretty tight coded application ..
    And we are supposed to trust that it's YOU who know what you are doing ?
    Somehow, I don't really think so !!
     
  16. wrathchild

    wrathchild Registered Member

    Joined:
    Feb 7, 2008
    Posts:
    170
    Location:
    Neoplantesis
    As a long-time user I've never had problems with NOD32 and TrueCrypt.
    Full system encryption, partition encryption, internal or external containers....no matter what.

    NOD32 v2.7 - v5
    TrueCrypt v5 - v7
    Windows XP 32-bit - Windows 7 64-bit
     
  17. learningdaily

    learningdaily Registered Member

    Joined:
    Feb 23, 2012
    Posts:
    1
    Location:
    US
    Marcos,

    Can you send me the replacement sys file as well? I'm experiencing a similar BSOD on Windows 7 x64 clients with NOD32 installed.
     
  18. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,330
    Hello,
    do you already have v. 4.2.76 installed? I reckon it should already contain the fix.
     
  19. enduser999

    enduser999 Registered Member

    Joined:
    Apr 17, 2005
    Posts:
    418
    Location:
    The Peg
    Where is 4.2.76 downloadable form? The download page http://go.eset.com/us/download only shows 4.2.71 for Windows7
     
  20. razmichael

    razmichael Registered Member

    Joined:
    Feb 18, 2012
    Posts:
    9
    Location:
    Canada
    Cabox - I'm running V5 on a similar sounding system as your system and am dealing with the long boot times - see my post http://www.wilderssecurity.com/showthread.php?p=2023053#post2023053 - disable the HIPS auto protect and boot times are normal (still waiting for a final solution). I also have a external HDD fully encrypted with Truecrypt and have no problems with it mounting under V5.
     
  21. pino123

    pino123 Registered Member

    Joined:
    Apr 5, 2012
    Posts:
    1
    Hi Marcos

    could you please send me too the replacement sys file?

    Thank you
     
  22. enduser999

    enduser999 Registered Member

    Joined:
    Apr 17, 2005
    Posts:
    418
    Location:
    The Peg

    Try installing the 4.2.76 version of NOD32 which is available under the Business section at http://go.eset.com/us/download# no idea if the business version will work with home user keys or not. I know it solved my TrueCrypt problem but I am using a business NOD32 key.
     
  23. foneil

    foneil Eset Staff Account

    Joined:
    Dec 7, 2010
    Posts:
    255
    Location:
    San Diego
Thread Status:
Not open for further replies.