Eset 4.2.64 BSOD with Truecrypt

Discussion in 'ESET NOD32 Antivirus' started by nurgle, Aug 23, 2010.

Thread Status:
Not open for further replies.
  1. sveinan
    Offline

    sveinan Registered Member

    Another ESET 4.2.71.2 BSOD with Truecrypt

    Just discovered that the "minesweeper" BSOD-or-not feeling :rolleyes:, of mounting TrueCrypt disks on my newly built Win7 x64 SP1 machine, is probably caused by ESET Smart Security (4.2.71.2).

    I would very much like to try the updated eamonm.sys (.inf & .cat) driver talked about in this thread.

    @Marcos Any chance ? Would like to avoid going Beta/RC v5 for now.
  2. bdool
    Offline

    bdool Registered Member

    I've the same issues with Win7x64 and NOD32 + Truecrypt 7a

    May someone PM me the updated eamonm.sys file ?

    Thanks

    B.
  3. mantra
    Offline

    mantra Registered Member

    does someone try TrueCrypt 7.1 ?
  4. TBubba
    Offline

    TBubba Registered Member

    With ESS 4.2.71.2 I still get a BSOD (although I'm using Smart Security not Antivirus, I suspect we share the same eamonm.sys file).

    Disable "boot sectors" under real-time protection, ThreatSense setup didn't help me.

    However, upgrading to ESS 5 RC 5.0.84.0 seems to have fixed the issue.

    Windows 7 x64 Pro SP1
    TC 7.1
    ESS 4.2.71.2 (BSOD on mounting TC volume)
    ESS 5.0.84.0 (no problem so far)
  5. reza666
    Offline

    reza666 Registered Member

    Even though i got it working using the new .sys file i find it strange that Eset hasnt made a update to their v4.2 for over a year (more?). After all they do sell the product. Very shaddy way of handling this issue in my opinion.

    This problem is solved in V5 but i get worried what will happen if a bug like this is found up in V5. Will we have to wait for V6? I have lost a bit of confidence in Eset to be honest specially since this problem has been known for sooo long and so many people reported it. After all this is a serious problem and not a good to have "thing".

    Hoping for some improvement on Eset's side.
  6. Marcos
    Online

    Marcos Eset Staff Account

    A fix to this issue was made not more than 2-3 months ago. It's a very short time for releasing a new version, especially that further development of v4 is basically discontinued and all efforts are now concentrated on v5.
    The fixed drivers are provided on demand to whomever asks for them.
  7. Calafax
    Offline

    Calafax Registered Member

    No. They're not.

    And that's "whoever" asks for them.
  8. Marcos
    Online

    Marcos Eset Staff Account

    I've always provided the new drivers to whomever asked me for them. I'll drop you a PM.
  9. BassGeek
    Offline

    BassGeek Registered Member

    I would LOVE to have the fix for this issue as well. (Win7 - 64bit)

    Thanks
  10. focus
    Offline

    focus Registered Member

    I asked for this updated .sys file once before and never received it. Using 4.2.71.2 on Win7 64. As I am not planning on upgrading our systems to v5 for a few months the ability to use Truecrypt with no worries would be very welcome.

    edit: Thank you Marcos, update information received.
    Last edited: Sep 8, 2011
  11. Jadoube
    Offline

    Jadoube Registered Member

    Update... I switched computers a while back and was able to try both ESET 4 and 5 and even back and forth a bit. With Win7 x64; ESET 5.0.84 and TrueCrypt 7.0a or 7.1 I have never seen a blue screen. With ESET 4.x blue screens returned.
  12. Mike P
    Offline

    Mike P Registered Member

    I haven't experimented with Eset, but the bluescreen only happens when FAT TrueCrypt volumes are mounted. Stick to NTFS formatted volumes and I have no problem.
  13. Jadoube
    Offline

    Jadoube Registered Member

    I only use NTFS. All my blue screens happen with NTFS.
  14. mantra
    Offline

    mantra Registered Member

    did you try v5 final?
  15. Jadoube
    Offline

    Jadoube Registered Member

    Its not released yet? build 84

    Regarding BSODs... consistently a couple of times a week; any version of ESET v4 always with NTFS volumes.
    I have never seen a blue screen with any version of ESET beta 5
  16. agoretsky
    Offline

    agoretsky Eset Staff Account

    Hello,

    ESET NOD32 Antivirus Version 5 was released yesterday on September 13th.

    Regards,

    Aryeh Goretsky


  17. Jadoube
    Offline

    Jadoube Registered Member

    Ah Thanks. Upgraded. I guess I thought the beta would auto update... but maybe it's a different update server (which makes sense).

    Anyway... no problems so far. Is this "issue" officially fixed?
  18. AxelF
    Offline

    AxelF Registered Member

    @Marcos:
    I sent a request for the 4.2 patch to you via PN. Is it ok that way?
  19. locked_mountain
    Offline

    locked_mountain Registered Member

    I'll say this. I'm running Truecrypt system encryption 7.1 now, I haven't had any BSOD's with Nod32 v5.0.93.0, and never had an issue with the previous Nod32 v.4.67.10 when I was running Truecrypt 7.0a. However, now I am experiencing very long mounting times with Nod32 V5. It takes about 15 to 20 seconds to mount where as with previous versions of Nod32 it only took me about 2 seconds.

    I'm hoping this delay in mounting drives has more to do with a scanning issue and not something else.

    Edit: I tried adding both the device drive letters shown in MyComputer as well as the mounted volume letter assignments to the "exclusions" list, ..ie D:\*.* , E:\*.* , F:\*.*...ect... but it's still taking a long time to mount. But they all do mount ok so I don't know what to make of it.

    --- this system ---
    Win XP 32bit / spk3
    Last edited: Sep 18, 2011
  20. AxelF
    Offline

    AxelF Registered Member

    @Marcos:
    Sorry, may I ask for a reply, or a PN?

    Thanks in advance.
  21. AxelF
    Offline

    AxelF Registered Member

    @Marcos:
    I see you are online and posting here every day. Why isn't is possible to give a short reply?
  22. AxelF
    Offline

    AxelF Registered Member

    And again I got a bluescreen. It's a pity that the business edition is still only available in 4.x, and no patch recieved me yet, no answer either. :-/
  23. Doraemon
    Offline

    Doraemon Registered Member

    Hi all. I'd like to know if this BSOD issue is fixed in the 5.0 versions of ESET.

    Thanks! :D :D :D
  24. AxelF
    Offline

    AxelF Registered Member

    @Marcos:
    Thanks for the patch. Seems to run well. Future will show us. :thumb:
  25. Nage
    Offline

    Nage Registered Member



    Hello, I have the same question
Thread Status:
Not open for further replies.