"Could not Connect to Server" Clients Intermittently Losing Connection to ERAS

Discussion in 'Other ESET Home Products' started by Arsynic, Aug 7, 2009.

Thread Status:
Not open for further replies.
  1. Arsynic

    Arsynic Registered Member

    Jun 9, 2009
    I've had this problem off and on for a couple of weeks, but now it's more frequent and longer in duration.

    My clients aren't able to update from the ERAS. In the past, stopping and restarting the ERAS service did the trick. However, it's not working.

    I can ping the server from the clients and the client status is updating in the Admin console, but they're just not pulling updates.
  2. Rmuffler

    Rmuffler Former Eset Moderator

    Jun 26, 2008
    San Diego, CA USA
    Hello Arsynic,

    Are you having an issue with port 2222 also?

    Our support engineers can help you resolve this. Creating a SysInspector log for the server and a client will assist them in diagnosing the issue. You can submit a support request here: http://www.eset.com/support/contact.php. Attach your SysInspector logs in the response email you receive from the support team.

    Thank you,
  3. Vtenkate

    Vtenkate Registered Member

    Jun 11, 2009

    We are expiriencing the same problems. Did you get any result from ESET by sending the SysInspector log?

  4. Marcos

    Marcos Eset Staff Account

    Nov 22, 2002
    When there's a problem updating from the ESET mirror, we always need to get the following stuff for perusal (upload them to an ftp server or contact ESET for anonymous access to their ftp):
    - the content of the mirror folder
    - the content of the "C:\Documents and Settings\All Users\Application Data\ESET\ESET Smart Security\Updfiles\" or the corresponding folder on Vista and newer OS
    - the exact message you're getting on the clients when attempting to update from the mirror

    In the case of problems updating via HTTP, you can try providing updates via a Windows share (the clients must have read access to the share granted).
  5. rockshox

    rockshox Registered Member

    Oct 23, 2009
    We had this exact same problem numerous times using the HTTP server built into ERA. After several support cases to ESET and providing SI logs and screenshots didn't resolve the problem we were recommended to switch to IIS to serve updates. Since I've setup IIS7 to serve updates we haven't had a single issue.

    Also to note, the clients download the updates from IIS probably 15x faster than the ESET http server, so there was a performance increase going to IIS.
Thread Status:
Not open for further replies.