Comodo won't let me connect to the internet

Discussion in 'other firewalls' started by notageek, Nov 8, 2006.

Thread Status:
Not open for further replies.
  1. notageek

    notageek Registered Member

    Joined:
    Jun 3, 2002
    Posts:
    1,601
    Location:
    Ohio
    I'm trying this firewall again and now I can't connect to the internet. I don't have block all checked. I have to check allow all to connect. anyone kinow how to fix this?
     
  2. Banshee

    Banshee Registered Member

    Joined:
    Nov 10, 2004
    Posts:
    543

    Did you try doing an "automatic" installation and then *untick* "Do not show any alerts for the applications certified by Comodo" ?


    That should get you going. Once you done that, you could check Stem's post.

    here->http://www.wilderssecurity.com/showthread.php?t=145704&highlight=comodo firewall setup

    Hope it helps
     
  3. notageek

    notageek Registered Member

    Joined:
    Jun 3, 2002
    Posts:
    1,601
    Location:
    Ohio
    Yeah I did that, I can't access the web when I do it that way. I tried everything to fix this. It's kind of pointless to have a firewall if you have to allow all just to get get to web pages and emails.
     
  4. Pedro

    Pedro Registered Member

    Joined:
    Nov 2, 2006
    Posts:
    3,499
    Check the Comodo web site and forum
     
  5. notageek

    notageek Registered Member

    Joined:
    Jun 3, 2002
    Posts:
    1,601
    Location:
    Ohio
    Thanks everyone. I got it to work. I uninstalled Comodo and deleted every reg keys I found and re-install Comodo.
     
  6. Graystoke

    Graystoke Registered Member

    Joined:
    Aug 15, 2003
    Posts:
    1,502
    Location:
    The San Joaquin Valley, California
    This is exactly the same problem I had last night when trying to run Comodo firewall. I tried everything except cleaning out the registry. I didn't think that was necessary since it was the first time I tried Comodo. I'll check the registry to see if I can get it working.
     
  7. Graystoke

    Graystoke Registered Member

    Joined:
    Aug 15, 2003
    Posts:
    1,502
    Location:
    The San Joaquin Valley, California
    I still can't connect to the internet with Comodo installed. Comodo removed and Sunbelt Kerio 4 back on. I don't think too highly of Comodo firewall. :thumbd:
     
  8. Pedro

    Pedro Registered Member

    Joined:
    Nov 2, 2006
    Posts:
    3,499
    Well you'd have to post in Comodo forum to check what's wrong. I think it's quite possible you didn't uninstall properly Kerio. The uninstaller didn't work as it should or you didn't reboot. From there you install, and choose automatic config. IF that won't do it, try the forum. I could be a conflict with a software or something. Don't say you don't like Comodo if you couldn't make it work. It works for alot of people.;)
    I'm not atacking you, but since i'm a Comodo fan... You know. It has to work. You don't have to pay for a firewall. Comodo rocks, you see?:D
     
  9. notageek

    notageek Registered Member

    Joined:
    Jun 3, 2002
    Posts:
    1,601
    Location:
    Ohio
    Try to uninstall Kerio, reboot, find Kerio registry keys in the registry, delete them, reboot and try to install Comodo. See if that works. Make sure you delete all the reg keys for Comodo before you install it. Also make sure you backup your registry before you remove any files.
     
  10. Graystoke

    Graystoke Registered Member

    Joined:
    Aug 15, 2003
    Posts:
    1,502
    Location:
    The San Joaquin Valley, California

    Hi notageek. Yeah, I tried that. I started deleting Comodo registry keys, but got stuck when I couldn't delete this key......

    Name: DeviceDesc, Type: REG_SZ, Data: Comodo Application Agent.

    I kept getting this message.....

    Error Deleting Values: Unable to delete all specified values.

    I had to give up since I don't know how to get around that.
     
  11. notageek

    notageek Registered Member

    Joined:
    Jun 3, 2002
    Posts:
    1,601
    Location:
    Ohio
    I'm sorry, I don't know what else to do. Maybe someone else wioll come along with help.
     
  12. TairikuOkami

    TairikuOkami Registered Member

    Joined:
    Oct 10, 2005
    Posts:
    2,134
    Location:
    Slovakia
    When CPF service is running, the registry protection is active.

    Boot to safe mode - hold F5 during boot and choose Safe Mode.
    In safe mode remove the folder: "C:\Program Files\Comodo\Firewall".
    You can use this reg file to delete reg keys or you can do it manually:
    Code:
    Windows Registry Editor Version 5.00
    
    [-HKEY_LOCAL_MACHINE\SOFTWARE\ComodoGroup]
    [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Management\ARPCache\Comodo Firewall]
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
    "Comodo Firewall"=-
    
    [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Comodo Firewall]
    [-HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\LEGACY_CMDAGENT]
    [-HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\LEGACY_CMDMON]
    [-HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\LEGACY_INSPECT]
    [-HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\CmdAgent]
    [-HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\CmdMon]
    [-HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Inspect]
    [-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_CMDAGENT]
    [-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_CMDMON]
    [-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_INSPECT]
    [-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CmdAgent]
    [-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CmdMon]
    [-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Inspect]
    [-HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo]
     
Thread Status:
Not open for further replies.