Can't prevent mounting of NTFS volumes

Discussion in 'NTFS for Mac & ExtFS for Mac' started by Audio01, Nov 10, 2010.

Thread Status:
Not open for further replies.
  1. Audio01
    Offline

    Audio01 Registered Member

    Hi,

    Once Paragon NTFS for Mac v8.0 is installed I can't prevent the mounting of NTFS volumes with the fstab method under Mac OS X.

    For example if the volume label is "Windows", this entry in the fstab file:

    LABEL=Windows none ntfs ro,noauto

    won't do anything. Without Paragon NTFS for Mac installed, it works as designed.

    The question is: Is the file system identifier different when running NTFS for Mac? For example if NTFS-3G is installed and running, the entry should look like this:

    LABEL=Windows none ntfs-3g ro,noauto

    BTW, this is very useful, for example, for hidding (and no messing with) the Boot Camp Windows' system partition. I only want to see shared data partitions!

    Any input welcome. Thanks!
  2. Mech_An
    Offline

    Mech_An Registered Member

    I suppose, you should modify the entry as follows:
    LABEL=Windows none ufsd_NTFS ro,noauto
  3. Audio01
    Offline

    Audio01 Registered Member

    Hi,

    Thank you for your quick answer.

    I tried with "ufsd_NTFS" and it's not working. Seems that Paragon is changing something in the way the filesystem works.

    Any other idea? Thanks!
  4. Mech_An
    Offline

    Mech_An Registered Member

    try the following:

    LABEL=Windows none ufsd_NTFS rw,noauto
  5. Audio01
    Offline

    Audio01 Registered Member

    Hi again,

    Already tried it. No go.

    Investigating more it seems that there's something wrong in the way Paragon NTFS for Mac handles (identifies) volumes.

    The problem isn't the filesystem type identification (in this case "ufsd_NTFS"). The problem is with the volume label, that's in some way corrupted when NTFS for Mac is active.

    Take a look at this:

    in Terminal I do a "diskutil info" of the volume and this is the result:

    Code:
    bash-3.2# diskutil info /dev/disk0s2
    
       Device Identifier:        disk0s2
       Device Node:              /dev/disk0s2
       Part Of Whole:            disk0
       Device / Media Name:      Untitled 2
    
       Volume Name:              Windows
       Escaped with Unicode:     Windows%FF%FE%00%00
    
       Mounted:                  Yes
       Mount Point:              /Volumes/Windows
       Escaped with Unicode:     /Volumes/Windows
    
       File System:              UFSD_NTFS_COMPR
       Type:                     ufsd_NTFS
       Name:                     Windows NT Filesystem (compressed)
    
       Partition Type:           Windows_NTFS
       Bootable:                 Not bootable
       Media Type:               Generic
       Protocol:                 SATA
       SMART Status:             Verified
    
       Total Size:               32.2 GB (32210196480 Bytes) (exactly 62910540 512-Byte-Blocks)
       Volume Free Space:        6.2 GB (6187520000 Bytes) (exactly 12085000 512-Byte-Blocks)
    
       Read-Only Media:          No
       Read-Only Volume:         No
       Ejectable:                No
    
       Whole:                    No
       Internal:                 Yes
    
    Take a look at the volume label "escaped with Unicode": Windows%FF%FE%00%00

    What is that garbage after the real name? If I disable NTFS for Mac, the volume label appears correctly (and I mean even "escaped with Unicode").

    So you can't prevent the mounting of a volume with the fstab file, because the label is corrupted/wrong!

    Worst, if you try, you can't even unmount the volume at Terminal with a simple command like this:

    Code:
    bash-3.2# diskutil unmount Windows
    Unmount failed for Windows
    
    This works with any other volume, and with this same volume "Windows" with NTFS for Mac disabled!

    Also there's another anomaly in the way NTFS for Mac detects the volumes. Check again the "diskutil info" output, now at the name of the filesystem. It says "Windows NT Filesystem (compressed)". You can see that also in the Disk Utility app and my volume is NOT compressed!

    There's a third problem, about the way NTFS for Mac detects when a volume is an NTFS volume. It's using the "magic number" 0xAA55 on the VBR (Volume Boot Record). Microsoft says that this signature is only needed when a partition (volume) has bootable code. Theres a KB article about this at Microsoft. I tested it myself and Windows detects perfectly an NTFS partition without this signature (Mac OS X without NTFS for Mac does it too).

    Why I'm saying this? Because having the 0xAA55 signature in all partitions (volumes) confuses some boot managers (example rEFIt). To a boot manager all partitions with this signature could be bootable (and show in, for example, a multi-boot menu) and this isn't always the case. I want my data partitions out of this menu without the boot code signature (0xAA55) but detectable/mountable by NTFS for Mac!

    The correct way of detecting an NTFS partiton (volume) is by it's OEM string after the Jump/Nop instructions. The OEM string is at offset 0x03 to 0x0A in the VBR.

    Cheers!

    EDIT: Tested all this in Tuxera NTFS 2010.10 and it works perfectly!
    Last edited: Nov 10, 2010
  6. jwilliams108
    Offline

    jwilliams108 Registered Member

    I have noticed this issue as well. Has there been any progress or official response on how to detail with choosing not to mount particular drives?
  7. jwilliams108
    Offline

    jwilliams108 Registered Member

    Is this issue present in version 9?
  8. Mephist
    Offline

    Mephist Paragon Support

    You can create /etc/fstab file to manage access type (rw or ro).
    The file /etc/fstab is consulted for user-defined mount points, indexed by filesystem, in the mount point determination for a filesystem. Each filesystem can be identified by its UUID or by its label, using the constructs ``UUID'' or ``LABEL'', respectively. For example:
    LABEL=BOOTCAMP none ufsd_NTFS ro (mount volume BOOTCAMP with read-only access)
    LABEL=EXTERNAL_NTFS none ufsd_NTFS rw (mount volume EXTERNAL_NTFS with read and write access)
    LABEL=DONT_AUTO_MOUNT_THIS_VOLUME none ufsd_NTFS rw,noauto
    (this volume won't be mounted automatically).
    ufsd_NTFS - name of Paragon NTFS driver for Mac OS X.

    If it doesn't work with LABEL, try to use volume UUID.
  9. jwilliams108
    Offline

    jwilliams108 Registered Member

    Mephist - Thanks, but please read the full post by Audio01. This does not work as there seems to be some issue with drive names (labels) and Paragon NTFS. UUID also does not work.
  10. Mephist
    Offline

    Mephist Paragon Support

    Seems that this issue is fixed in 9th version. I can't reproduce it on my Mac...
Thread Status:
Not open for further replies.