cant install nod32 2.7 please help

Discussion in 'ESET NOD32 Antivirus' started by cookie1977, Dec 22, 2007.

Thread Status:
Not open for further replies.
  1. cookie1977
    Offline

    cookie1977 Registered Member

    I've been running 2.7 and upgraded to the latests version of nod32 3.0.621 but I'm having the same problem with it that I've had with previous version re http/pop3 web protection not fully working.

    Anyway I uninstalled it but I cant reinstall nod 2.7. It says:

    "(115) The version of NOD32 being installed is incompatible with the already installed version. Pleas uninstall current version first."

    I've removed all the folders suggest on wilderssecurity and I've looked for any registry entries but to no avail. I've on system restore points to go back to so has anyone any other ideas?

    Thanks in advance
  2. ASpace
    Offline

    ASpace Guest

    Most likely there is some leftover of v3 and that is why v2 reacts this why.


    Go ahead with System Restore :thumb:
  3. NodboN
    Offline

    NodboN Registered Member

    Worse come worse, if everything else fails try the following steps:-
    1. Re-install the previous version V2.7.
    2. Reboot when prompted to.
    3. Disable NOD32 V2 from starting up with windows
    4. Reboot and uninstall V2.
    5. Remove all debris by launching a search for 'Eset' and 'NOD32.'
    6. You will now be able to install V3 without any glitches. :thumb:
  4. ASpace
    Offline

    ASpace Guest

    The OP wants to install v2.7 (but they can't) , not 3.0 ;)
  5. NodboN
    Offline

    NodboN Registered Member

    :p Uh-oh, my mistake in misreading that - you're right, here. :p

    cookie1977, disregard my suggestion, please.
  6. cookie1977
    Offline

    cookie1977 Registered Member

    Thanks HiTech boy and Nod Bon. I ment to say I have NO system restore not "on" (type to fast). Any other ideas?
  7. LowWaterMark
    Offline

    LowWaterMark Administrator

    Actually, just reverse NodboN's suggestion and try reinstall the new 3.0 again; reboot; uninstall; and so on. It may be that a fresh 3.0 install will let you get a good uninstall this time. Maybe there was a conflict as you unistalled it this last time, such as adriver or such getting left behind. Also, check for stray remnants related to ESET remaining after that uninstall.
  8. LowWaterMark
    Offline

    LowWaterMark Administrator

    EA installs some files in the Windows drivers directory:

    C:\WINDOWS\system32\drivers\

    eamon.sys
    easdrv.sys
    epfw.sys (might just be for ESS)
    epfwndis.sys (might just be for ESS)
    epfwtdi.sys (might just be for ESS)

    Do you have any of those remaining?
  9. Thankful
    Offline

    Thankful Registered Member

  10. cookie1977
    Offline

    cookie1977 Registered Member

    Ok I did try already reinstalling and uninstalling nod 3 which works fine but I still get the same error when trying to install nod2.7

    I searched the windows/system32/drivers folder for t any eset files (including the ones you stated) but there were none.

    I have windows cleanup utility installed and it has no nod/eset listings in it to uninstall.

    Thanks for all the tips so far. Any other ideas?
  11. ASpace
    Offline

    ASpace Guest

    Hopefully .

    If the OP runs EAV's installer , the installation will find previous remnants and will provide two options - Repair or Remove . Remove will do the job of removing everything left :thumb:


    These folders:
    - C:\Documents and Settings\All users\Application data\Eset
    - C:\Documents and Settings\your user\Application data\Eset
    - C:\Documents and Settings\your user\Local Settings\Application data\Eset

    Registry for ESET entries ?
  12. cookie1977
    Offline

    cookie1977 Registered Member

    Well reinstalling nod 3.0.621 does not result in the program detecting a previous install and is quite happy to install the program. So thats a no go I'm afraid.

    I've already removed all traces in the application data folders. It's still hating me. Aaaaagggghhh!

    Got any other ideas? Much appreciated.

    I've gone through the registry and removed all nod32 entries. I've removed all ESET entries I could find which was a pain in the *** as it keeps showing me lists for rESET and sESETtings. Took forever
  13. Thankful
    Offline

    Thankful Registered Member

    Do you run the Windows Installer cleanup utility??
  14. Flatiron
    Offline

    Flatiron Registered Member

    Post #10
  15. cookie1977
    Offline

    cookie1977 Registered Member

    Yes but to no avail. But I found a lone folder of ESET in this folder i must have missed:

    HKEY_USERS\S-1-5-21-1228005688-209081703-181929401-1005\Software

    All working fine. Now if only I could or ESET could solve my problem of the pop3 and http web protection error I keep getting with ever version of Nod 3.0 since the beta.

    Thanks a million for all your help people.
  16. roucou
    Offline

    roucou Registered Member

    Could explain which manipulation did you make to solve this problem please? Because I have the same problem like you and I don't know HKEY_USERS :)
  17. cookie1977
    Offline

    cookie1977 Registered Member

    If you click start, click run, type

    regedit

    and hit return it'll open up the registry editor. I found the eset reference in

    HKEY_USERS\S-1-5-21-1228005688-209081703-181929401-1005\Software

    This seemed to be the one causing the problem. I just deleted the eset folder and it rectified the problem.
  18. roucou
    Offline

    roucou Registered Member

    It's strange , I deleted everything from ESET (I use some regcleaner like ccleaner, tune up utilities,etc...) But i always have the same message like you when I want to reinstall the NOD2.7.
    I don't know what I must do now... :-(
  19. cookie1977
    Offline

    cookie1977 Registered Member

    Manually search the registry for ESET and Nod32 entries. It's cumbersome because it'll find rESET and ESETtings but you'll get there.

    PS If you're not 100% confident dont mess with the registry!!
Thread Status:
Not open for further replies.