BartPE Plugin Paragon Backup & Recovery 10

Discussion in 'Paragon Drive Backup Product Line' started by TerryWood, Nov 9, 2009.

  1. SIW2
    Offline

    SIW2 Registered Member

    You're welcome.
  2. anuraag
    Offline

    anuraag Registered Member

    hey SIW2
    can you make a winbuilder script for paragon
    i want to use it with win7pe
  3. SIW2
    Offline

    SIW2 Registered Member

    I have no idea how to make a winbuilder script.

    I make my own pe builds

    If you already made something with winbuilder - you can add paragon manually.

    Just mount the boot.wim , create a folder in Program Files called PAR .

    Copy these from your installed paragon app. into the PAR folder.

    NLS
    Program
    Layout.ini

    You also need to make sure the "program" folder contains prgiso.dll and qtp-mt334.dll.
    They will be in your installed windows \system32 or sysWOW64

    You would want a shortcut of some kind as well - not sure how you do that with winbuilder made pe.

    Probably just drop one into the mounted wim USERS\DEFAULT\DESKTOP

    Unmount the wim with commit.

    You're done.
  4. anuraag
    Offline

    anuraag Registered Member

    i have created a script
    i am getting message 'task refresh failed message'
    do you know something about it
  5. SIW2
    Offline

    SIW2 Registered Member

    You don't get that message if you add paragon to the bog standard boot.wim ( from the 32 bit 7 install dvd ).

    Therefore , must be something missing in your winpebuilder made pe - might be a component - more likely a registry issue.
  6. anuraag
    Offline

    anuraag Registered Member

    can you tell me which registry needed for pe?

    i have added these
  7. SIW2
    Offline

    SIW2 Registered Member

    I don't include any of those - that is only used if you need a copy-on-write driver to run in windows ( instead of VSS ) - not needed in pe at all.

    I do not add any registry entries for Paragon . It just runs fully portably.

    The message you are getting indicates there is something about your pe build that is stopping paragon from operating properly.

    I do not know what it is - probably some of the registry entries you did when you made your pe in the first place.

    I can post up the entire registry of my own pe build, if you like.

    It includes Explorer, Sound , Video, themes, Aero, etc.
    Last edited: Jun 3, 2011
  8. u234
    Offline

    u234 Registered Member

    I tried to make a winpe3 paragon iso according to #97, but ended up with this message when booting from the cd and tried to run Paragon B&R 11:

    "Launcher.exe - Entry point not found"
    "the pocedure entry point ?size@QFile@@UBE_JXZ could not be located in the dynamic link library qtp-mt334.dll"

    Maybe I need to be running Win7 on the computer to make this work?
    I made the winpe on a Dell Dim. 8300 running Win XP.

    However all the other apps on the cd seem to work.
  9. SIW2
    Offline

    SIW2 Registered Member

    Sounds like you have the qtp-mt334.dl from series10.
  10. u234
    Offline

    u234 Registered Member

    This info is from the programs "About" screen:

    "Version information

    Paragon Backup & Recovery™, version 10.0.15.12802 (19.01.11 ) (Advanced) Free

    Components versions:

    hdm.dll, version 10.0, release 15, build 12802
    biont.dll, version 10.0, release 15, build 12802
    biont.sys, version 10.0, release 15, build 12802
    Paragon Base Services Library, version 1.1, build 11402 (19.01.11 )"
  11. SIW2
    Offline

    SIW2 Registered Member

    You should have qtp version 3.3.4.10 on the cd.

    Boot it up and have a look.

    It should be in x:\program files\PAR\program folder.

    Earlier versions of paragon kept qtp in system32 ( or syswow64 if you are running 64 bit o/s ) - so pecreator. copies that across if it finds it .

    If qtp is missing - or if you have an earlier version, e.g. 3.3.4.9 - you will get those messages.

    That might happeen if you had a previous version of Paragon installed and qtp from that is still in system32 ?
    Last edited: Jul 18, 2011
  12. u234
    Offline

    u234 Registered Member

    I have an old version of Paragon Drive Copy (v.8 PE) installed and I found qtp-mt334.dll v. 3.3.4.1 both on the CD and on the HDD in the system32 folder.
    Should I replace the file in the system32 folder with the newer v. 3.3.4.10 and do the procedure all over again to burn a new CD? Or is there a better way?
  13. SIW2
    Offline

    SIW2 Registered Member

    Yes, you need the newer qtp on the cd
  14. u234
    Offline

    u234 Registered Member

    I made a new CD with the newer qtp and now everything works just fine, thank You for correctly diagnosing the problem.
  15. SIW2
    Offline

    SIW2 Registered Member

    Thanks for the feedback.

    GLad it's working for you.:D