ADD says E000101F4: has not found any hard disk drives (after disk replacement)

Discussion in 'Acronis Disk Director Suite' started by AlterMind, Jul 31, 2009.

Thread Status:
Not open for further replies.
  1. AlterMind
    Offline

    AlterMind Registered Member

    ADDS says E000101F4: has not found any hard disk drives (after disk replacement)

    Hello ADDS support,

    I had to replace the failing HDD of my Compaq laptop and replaced it with a new SATA 250 GB disk from Samsung (model HM 250 JI, M5S). I have purchased an ADDS v10 license almost three years ago and made at that time a bootable CD which worked fine on the older disk/config, but it unfortunately doesn't recognise this new disk (when attempting to boot ADDS starts (Acronis rescue media shown) but when selecting ADDS "Full" (instead of "Windows" which isn't there) the load process ends-up with the following message:
    E000101F4: Acronis Disk Director Suite has not found any hard disk drives.​
    I downloaded the latest version 10.0.2160 of ADDS to get more recent bootable CD but that didn't work either. I have not found any "basic" way of loading ADDS instead of "Full" as I've read elsewhere here.

    I have a few of questions I'd like to submit to your attention:

    a) BootableCD update
    I've seen on this forum that you support folks would be able to create an updated bootable disk (.ISO file) ? Would you please do this for me and if yes what additional information would you need for that ?

    b) Further use of ADDS v10
    In the case the updated .ISO image would solve the boot issue, would I then be able to install again the full ADDS v10.0.2160 suite on the newly (re)created config ?

    c) Reuse of previous Recovery partition
    I took a copy of the Recovery Partition of my laptop before the disk crash on an external USB HDD. These are 9GB worth with all device drivers and Windows Vista localised software installation files and reusing that would tremendously reduce the pain to rebuild the whole software environment. Could I possibly use ADDS to create a similar partition structure as before, recopy the recovery partition files from the HDD and use it to reinstall my laptop for the Vista partition ? That config was:
    [X:] Compaq Recovery partition (9 GB, FAT32 presumably, I could explore it with Windows Vista or Total Commander)
    [C:] Windows Vista Home FR (80 GB, NTFS)

    d) More partitions
    Ultimately, I'd like to take "benefit" of the HDD failure situation I have to have more partitions to possibly try & learn Linux. I'm thinking of something like:
    [??:] ADDS boot manager/OS selector (1 GB)
    [X:] Compaq Recovery partition (9 GB, FAT32)
    [C:] Windows Vista Home FR (80 GB, NTFS)
    [D:] Data Disk partition (100 GB, what file system type ?)
    [??:] Linux/KDE/Ubuntu (or other?) partition (60 GB, Linux FS)
    Would something like the above be possible ? And if yes:
    d1) can I use my ADDS v10 as an OS Selector ?
    d2) is there any Linux version/build that would be able to use/read/write the D: partition in alternation with Vista (for example to read the music files, edit the OpenOffice documents, view the pictures, etc) and if yes what should be the file format to be used to format D: ? Which Linux builds/packaging would allow such alternative use ?

    Thank you veryu much in advance for your time, dedication and support!

    AlterMind
    Last edited: Aug 1, 2009
  2. ADDuser
    Offline

    ADDuser Registered Member

    I've recently installed Acornis Disk Director Suite 10.0 (build 2160). When started from within Windows (Win XP) it works fine. However, when started from the bootable CD (created with the program itself), then the program version on the CD recognises none of the two hard disks, saying: "Error E000101F4: Acronis Disk Director Suite has not found any hard disk drives."

    That appears very strange to me. In the BIOS screen I can see that both disks are recognised by the BIOS. Also other disk utilities (such as former PowerQuist Drive Image and Partition Magic) have no problem recognising the hard disks.

    Suffices to say that after the error message there is no alternative to get the program working.

    What is the problem and what can be done about it?

    Regards, Kees.
  3. K0LO
    Offline

    K0LO Registered Member

    Kees:

    When you use the bootable CD it contains its own operating system, which is Linux-based. Since Disk Director is about 2 years old now, its database of Linux hardware drivers is getting out of date. There are two solutions for the moment (until Acronis updates Disk Director):

    1. Use the "safe" mode version on the boot CD instead of the "full" mode version. Safe mode uses DOS and will work with any disks that are recognized by your BIOS. Full mode uses Linux. When you create a boot CD with the Bootable Media Builder application, be sure to include both full and safe mode versions on the CD.

    2. Log into your account on the Acronis web site and go to your Registered Products page. Under Disk Director 10, download the alternate ISO file. This file has updated drivers for the full-mode version. Burn it to a CD and use this version instead of the full-mode version furnished with the program.

    Solution #1 is the simplest, IMHO.
  4. ADDuser
    Offline

    ADDuser Registered Member

    The disks are plain serial ATA disks, about 2.5 years old, as is the rest of the hardware. I purchased the DDA two days ago (version 10.0, build 2160). One might expect that what is sold (as download) is the most recent version. I'll try to obtain the updated iso file (though some other posts on this forum suggest that this contains the same drivers).

    Moreover, the bootable version of True Image 11 (which I got about a year ago) and which is on the same bootable CD, recognises the disks whitout a hitch.

    You're quite correct that DDA in safe mode works, thanks for the tip. I had to start the DDA twice (the first time it returned to the main screen immediately, though I saw some messages flashing on the screen about analysing disks).

    Regards, Kees.
  5. K0LO
    Offline

    K0LO Registered Member

    Kees:

    It is usually the motherboard chipset's SATA controller that is the issue; not the disks.
  6. ADDuser
    Offline

    ADDuser Registered Member

    I see. The mother board is Asus P5B-E plus, and (copied form the box: an Intel P965 express chip set, 8x serial ATA). The device manager shows, amongst other, "Intel ICH8 2 port serial ATA Storage Controller -2825" and "Intel ICH8 4 port serial ATA Storage Controller -2820", in addition to Primary and Secondary IDE Channels.

    When logging in to my acronis account, I also have to provide my location.

    If I fill in Netherlands, then the updates under 'registered product' show the latest update of the DDA program iteself to be build 2160 dated March 1, 2007 (my recently acquired program also indicates build 2160). There is no alternate iso to find there.

    If, however, I indicate that my location is USA, then, in addition to the latest update of the DDA program (also build 2160, dated March 1, 2007) there is a separate tab for 'bootable media' with an iso file. Strangely, the web site also mentions "build 2160" and "March 1, 2007" for this iso file, which would be not much of an update. When downloaded, the iso file appears to contain files of October 10, 2008 and thus may indeed be an updated version, though the web site suggests otherwise.

    I've burned the iso file to CD and now the proof of the iso file is in the rebooting of the system ...
  7. ADDuser
    Offline

    ADDuser Registered Member

    Booting with alternate iso file is indeed different from booting with the bootable CD created from DDA. The alternate iso file appears to be linux-based (judging from the text that appears on the screen). It contains only the (full?) version of DDA build 2160.

    It recognises the disks, so that is indeed an important improvement.

    But it shows erratic behaviour with my (USB) mouse. Mouse left-right movement result in cursor up-down movements, no left-right movement and no clicking is possible. Though the program can be controlled by key strokes, I have not found out how to select a disk or partition and how to scroll through the list of disks. I expect the mouse problems can be solved by using a PS2 mouse, which is at least possible on my desktop (but not on the laptop).

    KOLO, thanks for all the reactions. At least I now have several alternatives to work with.
  8. AlterMind
    Offline

    AlterMind Registered Member

    Hi all,
    I'm updating my initial request with the current findings, just in case it may help other people.

    a) BootableCD update
    I have found the update on Acronis.com's website, after logging-in, under My Account > RegisteredProducts > "Bootable media" tab for ADDS.
    This .ISO file is 15,1 MB big and is curiously quite smaller than the 27,0 MB large .ISO generated by the full 10.0.2160 version.

    But once burnt on a CD and booted, it didn't fail with the E000101F4 error like the generated version did. That was a significant step forward, but wasn't able to use the regular mouse, as its movement was too erratic, so I used the touchpad and that went fine.

    On the contrary of what was said here above, I wasn't offered any "safe" mode to boot: I was at once (after a long delay) offered the a graphical interface allowing me to choose between "lauch full version" or "launch windows" (or alike). When is the "safe" option proposed ?

    With the bootable media ADDS I created the several Windows 7, Ubuntu and Data partitions I needed.

    b) Further use of ADDS v10
    Yes that seems to work fine, even when installed on Windows 7. I used it to resize the Windows 7 partition, get rid of a too small partition, merge contiguous unallocated areas, create a new partition, etc.

    c) Reuse of previous Recovery partition
    I could recopy back all the Factory Compaq Recovery files in the dedicated 9 GB FAT32 partition created for that purpose, but with 2 unexplained oddities so far:
    - First, I had to grow the partition several times to allow copying a very big file (almost 9 GB large), but even when the partition was as large 25 GB the copy of the bigfile would fail claiming there isn't enough disk space ! (o_O)
    I had to reformat the partition as NFTS to allow the copy of the big file to succeed. Any explanation on that ??
    - Second, the backup I took include a "Volume information" folder. However copying that one back failed, wasn't possible. Why would the copy to one direction work (backup) and not the restore of it ?

    I guess the next step would be to make that partition bootable (it was created as a primary partition) and possibly use it to restore the initial Windows Vista Home Premium FR in case my experience with the yet installed Windows 7 would be too disappointing...

    d) More partitions
    d1) I'm not using ADD OS selector, as once I had Ubuntu installed it offered its own basic, text-based selector. I like the idea to have a nicer GUI selector as the one proposed by ADDS OSS but I've read in this forum that it has some troubles recognizing Ubuntu partitions. Any idea/suggestion ?
    d2) Yes Ubuntu 9.0.4 reads nicely my NTFS formated DATA partition and I'm so far quite impressed by this Linux package and all its inclusions !

    Thanks for your experience sharing and possible feed-back !

    AlterMind
  9. K0LO
    Offline

    K0LO Registered Member

    If you create a recovery CD using the program's Bootable Media Builder application, you have the choice of including both "full" and "safe" mode versions on the CD. The updated ISO on the Acronis web site does not include a menu with the choices of full or safe; it is a full (Linux) mode version only.

    FAT32 has a maximum file size limitation of 4 GB. You will be unable to store a 9 GB file on a FAT32 partition.
    If you were doing the copy with the Windows version of DD, the System Volume Information folders are locked by Windows to prevent access. Ordinarily you should leave the operating system to manage these folders.
    I prefer Ubuntu's boot manager (GRUB) to OS Selector, but that's just me personally. Actually, the updated version of GRUB, called Grub4DOS, is even better because it understands NTFS partitions among other advantages.

    If you want to get OS selector working, start a new thread asking for help in getting OS Selector to recognize Ubuntu. Our local resident OS Selector expert, forum member MudCrab, will probably be glad to help you.
  10. AlterMind
    Offline

    AlterMind Registered Member

    Thanks for the replies, K0LO.
    Oh didn't know that. I thought I was safe as the FAT32 formatting process went ok, but indeed max partition size isn't max file size.

    Yes, once rebooted the Sys Vol Info folder was suddenly present. I tried to use ADDS to make it "active" (it was already primary), but once I tried to boot it I got a msg saying "NTLDR not found" or so. I guess it meant that this volume wasn't bootable. I gave up and deleted that partition to get back the disk space.

    On my current GRUB display, even though there are only 2 bootable OS'es, I'm shown 6 entries: 4 Ubuntu (2 versions and their recovery mode each) and 2 "Other" (the Windows 7, and the now deleted partition but still proposed). How can I edit this list to get rid of the unusabe / unwanted ones ?

    Ok thanks ! Note that if I like Grub4DOS I might drop considering OSS.
  11. K0LO
    Offline

    K0LO Registered Member

    The menu file for GRUB is a plain-text file that can be edited in any text editor. Boot to Ubuntu and open the file /boot/grub/menu.lst using gedit or your favorite editor (as root).
  12. AlterMind
    Offline

    AlterMind Registered Member

    Found it ! I'm gonna dive into those instructions now... and keep you posted :)
    Last edited: Aug 5, 2009
  13. AlterMind
    Offline

    AlterMind Registered Member

    Hi again,

    I had no clue about how to connect as root (I'm a very new Ubuntu user), but finally found a way. File "menu.lst" updated as desired, thank you very much K0LO !
    The displayed menu initially contained:
    Ubuntu 9.04, kernel 2.6.28-14-generic
    Ubuntu 9.04, kernel 2.6.28-14-generic (recovery mode)
    Ubuntu 9.04, kernel 2.6.28-11-generic
    Ubuntu 9.04, kernel 2.6.28-11-generic (recovery mode)
    Ubuntu 9.04, memtest86+
    Other operating systems:
    Windows Vista (loader)
    Windows Vista (loader)​

    I commented out items 3,4,5,6 and 8, and renamed the 7th, so it now only shows:
    Ubuntu 9.04, kernel 2.6.28-14-generic
    Ubuntu 9.04, kernel 2.6.28-14-generic (recovery mode)
    Windows 7​

    Is there any reason to keep the 2.6.28-11 kernel ? If not, can/should I remove some files (e.g. to save some disk space)?

    Thanks for the advice ! :)
  14. MudCrab
    Offline

    MudCrab Imaging Specialist

    Ubuntu usually keeps the last several kernels available for booting in case you have problems with a new one. I usually just leave them. In my opinion, the space recovered by deleting the files isn't worth the trouble. Plus, I've needed to use them several times.
  15. K0LO
    Offline

    K0LO Registered Member

  16. AlterMind
    Offline

    AlterMind Registered Member

    Thank you again Mark, you were most helpful to me.
  17. SteeleJohn
    Offline

    SteeleJohn Registered Member

    E000101F4: has not found any hard disk drives

    Hello ADDS support,

    I just purchased (4-Aug) Disk Director Suite and get the error "E000101F4: Acronis Disk Director Suite has not found any hard disk drives."

    I've tried booting using the "Safe" method as well as the more limited ISO file you mentioned. Neither way works.

    Strange that an "older" product like "Partition Magic 8" works immediately; not much sense in buying a "newer" product like Disk Director.

    When will the updated drivers, including SATA, be posted for Disk Director. Will we be eligible for an upgrade?
Thread Status:
Not open for further replies.