acronis vss provider removeable?

Discussion in 'Acronis True Image Product Line' started by ChristianF, Jun 22, 2006.

Thread Status:
Not open for further replies.
  1. ChristianF

    ChristianF Registered Member

    Jun 21, 2006
    Hi there!

    I have a major Problem with the Acronis VSS Provider; I made some screenshots and will guide you chronological through my problem which lasts already two days.

    For evaluation purposes i tried to install the actual Acronis True Image Enterprise Server TRIAL build 3633, but the

    installation failed, exactly with the same symptoms like in this thread:

    So i didnt follow up this problem...

    Next Day, i had a problem with my Veritas BackupExec for Windows Server V 10 Software, with following errormessages:

    So the Shadow Copies Components generating problems...a look in the Eventviewer:

    So the object {5fc845eb-f299-40f0-9725-34045f7ea8ba} makes the problems... after some research i identified the object. In the Component Services there is an entry called "Acronis VSS Provider"; So this entry must has been installed with the unsuccessful installation the day before. Weird.

    With the vssadmin command line tool, there is also an entry as hardware provider:

    I thought, it shouldn't be that hard to remove this entry. It cost me a whole day of research in the internet, but i didn't find any helping answers.

    Again, i never installed acronis on this server... maybe somebody here can help me


    Last edited: Jun 22, 2006
  2. Acronis Support

    Acronis Support Acronis Support Staff

    Apr 28, 2004
    Hello Christian,

    Thank you for your interest in Acronis Disk Backup Software.

    Please click Start->run->cmd and use the following command
    regsvr32 /u \windows\system32\snapapivss.dll to unregister snapapivss.dll.

    If the problem still persists, please submit a request for technical support using Ask a question before you purchase Acronis software link. Attach all the collected files and information to your request along with the step-by-step description of the actions taken before the problem appears and the link to this thread. We will investigate the problem and try to provide you with the solution as soon as possible.

    Thank you.
    Tatyana Tsyngaeva
  3. sbranham

    sbranham Registered Member

    Oct 10, 2006
    I finally fixed this annoying problem!. After researching on the Internet for an hour or so, I came upon this post showing the exact issue that I was having. Since I couldn't unregister snapapivss.dll since I had already uninstalled Acronis, I decided to just remove the VSS provider from the registry. I searched the registry for the CLSID of the VSS (in this case "da611") and removed that entry from the currentconrolset area (there were only 3 instances of it). Once that was done, I was able to use NTbackup to backup my files. Make sure you export that key first, just in case.
Thread Status:
Not open for further replies.