Acronis Can't Seem To Clone BitLocker Partition

Discussion in 'Acronis True Image Product Line' started by bigbw, Jun 19, 2009.

Thread Status:
Not open for further replies.
  1. bigbw
    Offline

    bigbw Registered Member

    I am using Acronis True Image Workstation 9.1 and trying to clone 1 identical SCSI 34 GB hard disk to another from Vista Ultimate SP1 to make a Vista test system clone of my production system on the same machine to allow me to check out updates in a test environment.

    The source disk has 3 partitions, an EISA (Dell disk utilities), Vista, and Vista Boot partition. Partition 2, the Vista partition is encrypted with BitLocker.

    When the Clone Wizard has finished and a reboot is done into the Acronis environment, the EISA partition copies okay, then when ATIW tries to copy the Vista BitLocker partition, it fails saying OPERATION ERROR: Invalid format.

    I went back into Vista and disabled BitLocker (so the partition is still encrypted but a key is no longer required) then retried but get the same error.

    Before I encrypted the drive with BitLocker the above cloning process worked perfectly, with ATIW changing the drive letters so the cloned disk would boot Vista correctly. My Vista partition needs drive letter C: to work, the Vista boot parition needs letter D: to work, which ATIW would happily assign to the cloned disk so that when I booted from either disk, I'd get C: and D: for the partitions.

    The Recovery disk version never did work correctly (it would get in a mess with the drive letters), so I can't use that.

    Out of desperation, I tried using a trial version of Acronis True Image Home 2009 but that fails with "Error #1364 A specified authentication package is unknown (0xFFF0)" before it even gets to reboot into the special Acronis environment.

    Out of even more desperation I tried a trial version of Acronis True Image Echo Workstation but this fails with exactly the same error as my True Image Workstation 9.1.

    Surely I don't have to take encryption off the BitLocker drive before Acronis will clone it?

    I have submitted a Web form request to Acronis support already, about 10 mins ago, because I wasn't aware of this forum's existence till after so any help here would be appreciated.

    Thanks
  2. Acronis Support
    Offline

    Acronis Support Acronis Support Staff

  3. bigbw
    Offline

    bigbw Registered Member

    Thanks for your suggestion.

    Using the Recovery disk with sector-by-sector backup and restore appears to reload Vista to the second hard drive but unfortunately the drive re-lettering that Clone Disk does is crucial and this vital step is missing when backing up/restoring.

    My "production" hard disk (source disk) has letters C: for Vista and D: for the small boot partition.

    When Clone Disk is done, the "test" hard disk (destination disk) is given these letters by Acronis.
    When the backup/restore is done, Vista insists that C: and D: still belong to the source disk and gives the destination disk letters E: and F:. So what then happens is that it initates the boot from F: but then carries on using C: on the source disk for the rest of the time.

    If I then disable the source hard disk in Device Manager and reboot I get a Preparing Desktop message then nothing except a blank screen, presumably because of the links to C: it can no longer find.

    The problem is definitely BitLocker related. I de-encrypted the source disk, then ran Clone Disk and it all cloned perfectly giving me a usable test system with C: and D: now assigned to its hard disk (when I boot from that hard disk).

    I still haven't heard from the Vista Web support yet apart from receiving an automated Email with a case number so I'm still stuck at the moment.
  4. Acronis Support
    Offline

    Acronis Support Acronis Support Staff

    Hello bigbw,

    Thank you for using Acronis True Image 9.1 Workstation

    I may recommend you the following workaround. Restore full drive backup once again, then before booting from that drive restore MBR from drive image. The drive letters issue should be resolved.

    Best regards,
    --
    Dmitry Nikolaev
  5. bigbw
    Offline

    bigbw Registered Member

    Thanks for that suggestion.

    I did the sector by sector backup with BitLocker enabled on the source disk and restored to the target disk.

    But I got a STOP 0x000000ED UNMOUNTABLE_BOOT_VOLUME when booting from the target disk.

    There are 3 partitions on the source disk, a Dell Utilities partition, Windows Vista, and a small "Boot" partition which holds Windows Boot Manager (the BCD stuff). The only partition that gets backed up sector by sector is the Windows Vista one because ATIW says it might be corrupted. The other two seem to get backed up with ATIW's "normal" method.

    I restored the 3 partitions first, then went back and restored the MBR like you suggested.

    I don't know if the whole hard disk can be forced to be backed up sector by sector and whether that would make a difference. I haven't found a way to do this in ATIW but if I remember correctly, Acronis True Image Home does have a box that can be checked to force sector by sector backup.

    I'll give the ATIW sector by sector backup and restore another go. This time I'll try disabling BitLocker on the source disk (so it is still encrypted but doesn't require a key) before I do the backup.
  6. bigbw
    Offline

    bigbw Registered Member

    No, that didn't work.

    Exactly the same thing happened as described in Post #3. Test system trying to use E:, F: and C:. Failing when it can't get to production system C: drive (it should be using test system E: drive - which I wanted ATIW to change to C:).

    Acronis Web support say cloning encrypted partitions is not supported and offered a similar workaround to what you suggested.

    It is a pity that ATIW couldn't clone the Vista partition in the same way as Vista's Complete PC Backup - within Vista rather than booting into its own special environment.
    I appreciate that running the backup within Vista means the backup is de-encrypted, but if ATIW did this, it would then be able to sort the drive letters out correctly, then I could re-encrypt the target disk. At least then the source disk would remain encrypted.

    I was wondering if Acronis True Image Workstation Universal Restore might help. I read that it can handle virtual disk images. If I backed up the source disk using Vista's Complete PC Backup, which creates an unencrypted VHD file, then used Acronis True Image Workstation Universal Restore to restore it to a real hard disk, would that give me an unencrypted clone of the source disk
    with the drive letters corrected?
    I would try it myself but that doesn't appear to be a product that is available for a free trial and don't want to spend money if it won't work.
  7. surge
    Offline

    surge Registered Member

    Hey there, I am having a similar problem.
    I have a vista x64 ultimate system and my boot drive is encrypted with bitlocker.

    I got a newer and faster hard drive that I wish to replace the boot drive with...however, I can't seem to find ANY tools that will clone my existing one properly.

    Do you have any suggestions?

    Acronis trueimage gives me the same error you got, Invalid Format (sigh).

    The only workaround I can seem to think of is disable bitlocker and unencrypt the drive, then clone it, and re-enable.
    So much work..damn! Going to take hours!!
Thread Status:
Not open for further replies.